Make WordPress Core

Opened 15 months ago

Closed 15 months ago

Last modified 14 months ago

#57800 closed defect (bug) (reported-upstream)

Distraction free mode does not hide the Custom Fields panel

Reported by: psykro's profile psykro Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.2
Component: Editor Keywords:
Focuses: ui Cc:

Description

When switching to the new distraction-free mode in WordPress 6.2, if the user has enabled the Custom Fields panel, the panel is not hidden when distraction-free mode is enabled.

Tested on WordPress 6.2-beta3. To reproduce, enable the Custom Fields panel in the Editor preferences, and then enable Distraction-free mode

https://jonathanbossenger.com/wp-content/uploads/2023/02/custom-fields-enabled-scaled.jpg

Change History (7)

This ticket was mentioned in Slack in #core-editor by jon_bossenger. View the logs.


15 months ago

This ticket was mentioned in Slack in #core-test by ironprogrammer. View the logs.


15 months ago

#3 @ironprogrammer
15 months ago

  • Keywords reporter-feedback added

Thank you for the report, @psykro!

Because this requires updates to the editor, please open an a Gutenberg Issue. I'll leave this ticket open for now, but after it's been reported in GitHub, this ticket should be closed with reported-upstream.

(Also note that I was able to reproduce this with Gutenberg 15.3.0-rc.1 active, as well.)

#4 @psykro
15 months ago

Thanks @ironprogrammer, I wasn't sure if it should be logged there or here during the beta/RC phase.

I've created the ticket in GitHub.

#5 @ironprogrammer
15 months ago

  • Focuses ui added
  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to reported-upstream
  • Status changed from new to closed

Excellent, thanks for the follow-up, @psykro!

Regarding this ticket's applicability to 6.2, it might be characterized as a bug or enhancement, which would impact how it's milestoned. I'll raise this with the release squad for consideration.

Closing here with reported-upstream via https://github.com/WordPress/gutenberg/issues/48909.

#6 @wildworks
14 months ago

This issue has been fixed in Gutenberg(https://github.com/WordPress/gutenberg/pull/48947) and backported to WordPress 6.2. Is it possible to close this ticket?

#7 @ironprogrammer
14 months ago

Hi, @wildworks -- This was previously marked reported-upstream which closed it out here in Trac. Thanks for the update!

Note: See TracTickets for help on using tickets.