Make WordPress Core

Opened 15 months ago

Last modified 15 months ago

#58014 new defect (bug)

Invalid Post ID when updating a comment in editing

Reported by: wplmillet's profile wplmillet Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version: 6.2
Component: Comments Keywords: has-testing-info needs-testing
Focuses: Cc:

Description (last modified by costdev)

Bug Report

Description

Invalid Post ID when i update a comment

Content of the post:

the comment made in front-end on a lorem post created by hand no feature image.

Content of the comment:

A test is when you are made to make little drawings to see if you are not crazy.

I just try to add the word: "Really" at the end of the comment

Environment

  • WordPress: 6.2
  • PHP: 7.4.1
  • Server: Apache/2.4.43 (Unix)
  • Database: mysqli (Server: 8.0.16 / Client: mysqlnd 7.4.1)
  • Browser: Chrome 111.0.0.0 (Linux)
  • Theme: Twenty Twenty-Three 1.1
  • Language : FR
  • MU-Plugins: None activated
  • Plugins:
    • WordPress Beta Tester 3.3.7

Steps to Reproduce

  1. Go to Posts > Add New and create a new post.
  2. On the frontend, add a comment.
  3. Click Edit.
  4. Add a word.
  5. Click Update.
  6. 🐞 Bug occurs.

Expected Results

  1. ✅ The post must be updated and the word added.

Actual Results

  1. ❌ I have the error message : Invalid Post ID
  2. ❌ Checking the content after the error. The content has not changed.

Change History (5)

This ticket was mentioned in Slack in #core by wplmillet. View the logs.


15 months ago

#2 @ben.greeley
15 months ago

I had the same issue when I was testing 6.2 which also happened in 6.1.1. What ended up being the issue for me is I was trying to edit a comment for a post that no longer existed, which resulted in the 'Invalid Post ID' error.

A similar existing Trac ticket explains the current shortcomings of the comments UI, which this appears to be related to. #52875

My conclusion is that this isn't necessarily a bug, but confusing choice in wording for the error message.

Last edited 15 months ago by SergeyBiryukov (previous) (diff)

#3 @costdev
15 months ago

  • Description modified (diff)

This ticket was mentioned in Slack in #core-test by ironprogrammer. View the logs.


15 months ago

#5 @ironprogrammer
15 months ago

  • Keywords has-testing-info needs-testing added
  • Version changed from trunk to 6.2

Welcome back to Trac, @wplmillet, and thank you for the report!

As mentioned during test triage, some other attendees were unable to reproduce the issue during the 6.2 release party (comment:2 notwithstanding), so hopefully we will see some additional reproduction results to this ticket. Please update the steps to test if there is anything missing.

Note: See TracTickets for help on using tickets.