Make WordPress Core

Opened 12 months ago

Closed 12 months ago

Last modified 12 months ago

#58561 closed enhancement (fixed)

Backport: Block theme previews

Reported by: onemaggie's profile onemaggie Owned by: isabel_brison's profile isabel_brison
Milestone: 6.3 Priority: normal
Severity: normal Version:
Component: General Keywords: has-patch gutenberg-merge
Focuses: Cc:

Change History (13)

#2 @kebbet
12 months ago

  • Keywords gutenberg-merge added

@onemaggie commented on PR #4627:


12 months ago
#3

@felixarntz @audrasjb would you please have another look?

@peterwilsoncc commented on PR #4627:


12 months ago
#4

During testing, I'm seeing an error when the active theme is a classic theme

  1. Activate the theme Twenty Twenty-One (classic theme)
  2. Click live preview on a block theme: twenty twenty-two
  3. An error message is displayed: The theme you are currently using is not compatible with the Site Editor.

The reverse case is unaffected: it's still possible to preview a classic theme while a block theme is active.

https://i0.wp.com/github.com/WordPress/wordpress-develop/assets/519727/8b984130-241e-4eb9-8fd5-cc43ec1c3a4b

@isabel_brison commented on PR #4627:


12 months ago
#5

During testing, I'm seeing an error when the active theme is a classic theme

I suspect this is due to the npm packages not being updated yet in core. Can you confirm @MaggieCabrera ?

@onemaggie commented on PR #4627:


12 months ago
#6

During testing, I'm seeing an error when the active theme is a classic theme

I suspect this is due to the npm packages not being updated yet in core. Can you confirm @MaggieCabrera ?

This is in fact not happening when testing that flow using Gutenberg trunk and core 6.2.2. I can't say of the top of my head what's causing it, I'm going to double-check, but most likely we are just missing the npm packages like you said.

@scruffian commented on PR #4627:


12 months ago
#7

During testing, I'm seeing an error when the active theme is a classic theme

I suspect this is due to the npm packages not being updated yet in core. Can you confirm @MaggieCabrera ?

This is not the reason why it was failing - we found the cause was an incorrect GET param on the button. Having said that we are still finding that the feature isn't working correctly on this branch because the npm packages aren't updated yet. I think we'll need to wait for this to be done before we can confirm that this is working as expected.

@peterwilsoncc commented on PR #4627:


12 months ago
#8

Thanks for the pointer, I tried running npm run sync-gutenberg-packages on this branch to see if I could test but without success. I'm going to leave it alone for the rest of the weekend and see if I have more success on Monday.

#9 @onemaggie
12 months ago

i think this one is missing the 6.3 milestone

#10 @isabel_brison
12 months ago

  • Owner set to isabel_brison
  • Resolution set to fixed
  • Status changed from new to closed

In 56059:

General: add block theme previews.

Adds a preview link to block themes in the themes screen, opening the previews in the site editor.

Props onemaggie, andraganescu, audrasjb, flixos90, peterwilsoncc, spacedmonkey, scruffian.
Fixes #58561.

@isabel_brison commented on PR #4627:


12 months ago
#11

committed in r56059 / 1ef856c.

#12 @kebbet
12 months ago

@isabel_brison Please set the milestone for this ticket to 6.3. Thanks!

#13 @isabel_brison
12 months ago

  • Milestone changed from Awaiting Review to 6.3
Note: See TracTickets for help on using tickets.