Make WordPress Core

Opened 12 months ago

Closed 11 months ago

Last modified 11 months ago

#58677 closed defect (bug) (fixed)

Backport: move new wp_block postmeta field to a top level field of wp_block in rest responses and rename to wp_pattern_sync_status

Reported by: glendaviesnz's profile glendaviesnz Owned by: isabel_brison's profile isabel_brison
Milestone: 6.3 Priority: normal
Severity: normal Version: 6.3
Component: Editor Keywords: has-patch
Focuses: Cc:

Description (last modified by glendaviesnz)

As [discussed here](https://github.com/WordPress/wordpress-develop/pull/4646#issuecomment-1603668189) this moves the sync_status postmeta to a top level field of wp_block, and also renames it to wp_pattern_sync_status as [discussed here](https://wordpress.slack.com/archives/C02QB2JS7/p1688091498250399).

The rename to wp_sync_status is not 100% confirmed yet, we can back that out if needed.

[Related GB PR.](https://github.com/WordPress/gutenberg/pull/52146)

Change History (17)

This ticket was mentioned in PR #4761 on WordPress/wordpress-develop by @glendaviesnz.


12 months ago
#1

  • Keywords has-patch added

As discussed here this moves the sync_status postmeta to a top level field of wp_block, and also renames it to wp_sync_status as discussed here.

The rename to wp_sync_status is not 100% confirmed yet, we can back that out if needed.

Related GB PR.

Trac ticket: [](https://core.trac.wordpress.org/ticket/58677)

@glendaviesnz commented on PR #4761:


12 months ago
#2

@TimothyBJacobs is this the sort of thing you were thinking in this comment?

@glendaviesnz commented on PR #4761:


11 months ago
#3

This will need to be merged alongside the next lot of editor updates to be pulled in as it is dependent on those.

@glendaviesnz commented on PR #4761:


11 months ago
#4

It would be good to have a test for the postmeta field being moved up to top level field in rest response - will try and get that added tomorrow.

#5 @glendaviesnz
11 months ago

  • Description modified (diff)
  • Summary changed from Backport: move new wp_block postmeta field to a top level field of wp_block in rest responses to Backport: move new wp_block postmeta field to a top level field of wp_block in rest responses and rename to wp_pattern_sync_status

@glendaviesnz commented on PR #4761:


11 months ago
#6

@aaronrobertshaw I have added that unit test. The e2e failures seem unrelated but I do not have the option to restart them.

@ramonopoly commented on PR #4761:


11 months ago
#7

Just to confirm that this PR also covers the changes in:

Unfortunately, I do not have that ability either. Perhaps @tellthemachines or @ramonjd could help here?

I too am not a member of the exalted group 😄

@glendaviesnz commented on PR #4761:


11 months ago
#8

Just to confirm that this PR also covers the changes in:

except for this bit which is only needed in plugin, not core.

@isabel_brison commented on PR #4761:


11 months ago
#9

I restarted the tests. They've been super flaky lately so failures are unlikely to be related to this PR.

@isabel_brison commented on PR #4761:


11 months ago
#10

Committed in r56160 / 7035b61.

#11 @swissspidy
11 months ago

  • Milestone changed from Awaiting Review to 6.3
  • Resolution set to fixed
  • Status changed from new to closed

@isabel_brison FYI you forgot the "#" when referencing the ticket number in your commit message.

Manually marking this as fixed now.

#12 @swissspidy
11 months ago

Though I actually have to say that "6.3" should really be "6.3.0" in that @since annotation.

But then again, AFAIK we don't typically add @since annotations for new fields being added.

I recommend checking with #core-restapi

#13 @isabel_brison
11 months ago

Thanks @swissspidy ! I'll ask about it in #core-restapi.

#14 @kebbet
11 months ago

  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Version set to trunk

Reopening for visibility, regardning the @since tag.

#16 @isabel_brison
11 months ago

  • Owner set to isabel_brison
  • Resolution set to fixed
  • Status changed from reopened to closed

In 56217:

Editor: fix since annotation in rest blocks controller class.

Changes 6.3 to 6.3.0 in the since annotation for the filter_response_by_context function.

Props swissspidy, peterwilsoncc, mukesh27.
Fixes #58677.

@isabel_brison commented on PR #4834:


11 months ago
#17

Committed in r56217 / ee7434f.

Note: See TracTickets for help on using tickets.