Make WordPress Core

Opened 9 months ago

Closed 9 months ago

Last modified 9 months ago

#58847 closed defect (bug) (fixed)

Block editor layout issue

Reported by: bhrugesh12's profile bhrugesh12 Owned by: audrasjb's profile audrasjb
Milestone: 6.3 Priority: normal
Severity: normal Version:
Component: Editor Keywords: has-patch commit reporter-feedback fixed-major
Focuses: ui, css Cc:

Description

In WP RC1
When i try to edit any post and page, then trying to add block via add icon in editor. It seems to be so far as per previous version compare.

Attachments (5)

wp-62.png (121.5 KB) - added by bhrugesh12 9 months ago.
wp-63-RC1.png (66.5 KB) - added by bhrugesh12 9 months ago.
Capture d’écran 2023-07-20 à 00.33.46.png (146.2 KB) - added by audrasjb 9 months ago.
Fullscreen mode - can't reproduce
Capture d’écran 2023-07-20 à 00.33.33.png (239.2 KB) - added by audrasjb 9 months ago.
Not Fullscreen mode - can't reproduce either
Wordpress-core-#58847.webm (3.2 MB) - added by bhrugesh12 9 months ago.

Change History (22)

@bhrugesh12
9 months ago

@bhrugesh12
9 months ago

#1 in reply to: ↑ description @bhrugesh12
9 months ago

Replying to bhrugesh12:

In WP 6.3 RC1
When i try to edit any post and page, then trying to add block via add icon in editor. It seems to be so far as per previous version compare.

#2 @huzaifaalmesbah
9 months ago

I also face this same issue.

Environment
OS: Macos 13.4.1
Web Server: nginx/1.25.0
PHP: 8.1.21
WordPress: 6.4-alpha-56267
Browser: Chrome 115.0.5790.98
Theme: Twenty Twenty-One
Active Plugins: No plugins activated.

https://i.ibb.co/KjB9nmY/Block-editor-layout-issue.png

#3 @huzaifaalmesbah
9 months ago

I again check with WordPress 6.3-RC1-56265. I also face this same issue.

Environment
OS: Macos 13.4.1
Web Server: nginx/1.25.0
PHP: 8.1.21
WordPress: 6.3-RC1-56265
Browser: Chrome 115.0.5790.98
Theme: Twenty Twenty-One
Active Plugins: No plugins activated.

https://i.ibb.co/KXk1076/Block-editor-layout-issue-6-3.png

@audrasjb
9 months ago

Fullscreen mode - can't reproduce

@audrasjb
9 months ago

Not Fullscreen mode - can't reproduce either

#4 follow-up: @audrasjb
9 months ago

  • Milestone changed from Awaiting Review to 6.3

I can't reproduce the issue using TT3 theme.
(Chrome / Mac OS / 13")

Let's still milestone this to 6.3.

#5 @isabel_brison
9 months ago

This issue was thought to be fixed in https://github.com/WordPress/gutenberg/pull/52356 which was included in 6.3 Beta 4.

I can reproduce it on 6.3 RC1, as well as on the 6.3 release branch, though I can't on trunk. Not 100% sure what's happening here, will continue investigating.

#6 in reply to: ↑ 4 @bhrugesh12
9 months ago

Replying to audrasjb:

I can't reproduce the issue using TT3 theme.
(Chrome / Mac OS / 13")

Let's still milestone this to 6.3.

Please check attached video for better understanding.

This ticket was mentioned in PR #4871 on WordPress/wordpress-develop by @isabel_brison.


9 months ago
#7

  • Keywords has-patch added

To avoid breaking updates.

Trac ticket: https://core.trac.wordpress.org/ticket/58847

Essentially copies the fix from the previous time we had this problem: https://github.com/WordPress/wordpress-develop/pull/4155#discussion_r1121383013

Hope we can make our popovers work with the latest versions of those packages before too much longer 😅 but given it's RC time again this seems like the safest option for now.

@huzaifaalmesbah commented on PR #4871:


9 months ago
#8

Thank you very much for this solution. @tellthemachines

#9 @mukesh27
9 months ago

Thanks @isabel_brison for the PR, Is it part of GB backport or we merge it right away?

#10 @azaozz
9 months ago

  • Keywords commit reporter-feedback added

I can reproduce it on 6.3 RC1, as well as on the 6.3 release branch, though I can't on trunk.

Mmmm, weird. Could it be some sort of "caching gremlins" (may even be npm caching the packages)? :)

Cannot reproduce it. Tested both trunk and the 6.3 branch, in Firefox and Chromium, specifically tested in /build (same as production) with SCRIPT_DEBUG disabled.

The patch seems simple enough, and safe enough so thinking it can be committed to trunk if that will facilitate testing (the latest nightly build is here: https://wordpress.org/nightly-builds/wordpress-latest.zip). Then anybody that is experiencing this can test trunk and see if it fixes it, and if yes we can backport it to the 6.3 branch.

#11 @isabel_brison
9 months ago

In 56284:

Editor: fix popover positioning.

Pins the floating-ui package versions to avoid breaking changes when they update.

Props ramonopoly, spacedmonkey, bhrugesh12, huzaifaalmesbah, audrasjb, azaozz.
See #58847.

#12 @isabel_brison
9 months ago

Thanks @azaozz! I've committed the patch to trunk.

I was able to reproduce the issue eventually on trunk by deleting the node_modules and reinstalling. For folks testing the fix, try doing this on both trunk and the 6.3 branch and check the popover positioning each time.

@isabel_brison commented on PR #4871:


9 months ago
#13

Committed to trunk in r56284. Pending testing on trunk to check the issue is fixed, we can then commit it to the release branch.

#14 @audrasjb
9 months ago

  • Keywords fixed-major added
  • Owner set to audrasjb
  • Status changed from new to reviewing

Adding fixed-major workflow keyword.

Self assigning for review and potential backport to branch 6.3.

This ticket was mentioned in Slack in #core by audrasjb. View the logs.


9 months ago

#16 @audrasjb
9 months ago

  • Resolution set to fixed
  • Status changed from reviewing to closed

In 56289:

Editor: fix popover positioning.

Pins the floating-ui package versions to avoid breaking changes when they update.

Props isabel_brison, ramonopoly, spacedmonkey, bhrugesh12, huzaifaalmesbah, audrasjb, azaozz.
Reviewed by audrasjb.
Merges [56284] to the 6.3 branch.
Fixes #58847.

Note: See TracTickets for help on using tickets.