Make WordPress Core

Opened 10 months ago

Closed 10 months ago

Last modified 10 months ago

#59030 closed defect (bug) (fixed)

Broken link on `WP_SimplePie_Sanitize_KSES` documentation

Reported by: crstauf's profile crstauf Owned by: sergeybiryukov's profile SergeyBiryukov
Milestone: 6.4 Priority: normal
Severity: normal Version:
Component: General Keywords:
Focuses: docs Cc:

Description

The link to the “SimplePie_Sanitize” class in the “See Also” section of the “wp_simplepie_sanitize_kses” documentation is broken.

The correct URL for the “SimplePie_Sanitize” class is {80% SURE}:

https://developer.wordpress.org/reference/classes/wp_simplepie_sanitize_kses/sanitize/

Please fix this broken link.

Thank you.

Reported by @luckybhumkar via User Contributed Notes.

Documentation:
https://developer.wordpress.org/reference/classes/wp_simplepie_sanitize_kses/#see-also

Change History (4)

#1 @swissspidy
10 months ago

  • Milestone changed from Awaiting Review to WordPress.org

This looks like an issue with DevHub as the link is automatically generated. So like all things related to dotorg I recommend filing a ticket at https://meta.trac.wordpress.org/ instead.

#3 @SergeyBiryukov
10 months ago

  • Owner set to SergeyBiryukov
  • Resolution set to fixed
  • Status changed from new to closed

In 56379:

Docs: Remove @see references for SimplePie classes.

As SimplePie is an external library, these classes are not parsed for the WordPress Code Reference, so the @see tags were linking to non-existing pages.

Follow-up to [38112].

Props crstauf.
Fixes #59030.

#4 in reply to: ↑ description @SergeyBiryukov
10 months ago

  • Milestone changed from WordPress.org to 6.4

Thanks for the ticket!

This appears to be caused by the @see tags linking to SimplePie classes in some core files.

Should be resolved by [56379], but won't be visible until the docs are parsed for the WP 6.4 release.

The correct URL for the “SimplePie_Sanitize” class is {80% SURE}:

https://developer.wordpress.org/reference/classes/wp_simplepie_sanitize_kses/sanitize/

That's a page for the WP_SimplePie_Sanitize_KSES::sanitize() method, so not quite the same.

Note: Looks like I missed the props for @luckybhumkar here. Sorry for that! I have updated the props list for [56379] in the Core Props tool on make/core to correct that.

Note: See TracTickets for help on using tickets.