Make WordPress Core

Opened 10 months ago

Closed 5 months ago

Last modified 5 months ago

#59409 closed defect (bug) (reported-upstream)

Remove unwanted space in the string

Reported by: mujuonly's profile mujuonly Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.3
Component: I18N Keywords: has-patch
Focuses: Cc:

Description

Remove unwanted space in the string. Space shows warning at translation

Change History (8)

This ticket was mentioned in PR #5259 on WordPress/wordpress-develop by @mujuonly.


10 months ago
#1

  • Keywords has-patch added

Removed unwanted space in the string

Trac ticket: https://core.trac.wordpress.org/ticket/59409

@mukesh27 commented on PR #5259:


10 months ago
#2

@SergeyBiryukov @costdev Could you please take a look.

#3 @sabernhardt
10 months ago

  • Component changed from General to Editor
  • Focuses accessibility added
  • Type changed from enhancement to defect (bug)
  • Version set to 6.3

The string with a "Read more" link was added in GB51190.

The space at the beginning does not bother me, but the string should be edited anyway. These links can share identical text with all other post excerpts in the block. The block seems to have trouble with the excerpt_more hook, too.

This ticket was mentioned in Slack in #accessibility by joedolson. View the logs.


10 months ago

#5 @joedolson
10 months ago

  • Component changed from Editor to I18N

I agree; this link is a definite accessibility problem. This needs a little research; I remember looking at the read more links in GB previously and I feel like the linked PR is possibly a regression against an earlier state.

However, the reported issue is an internationalization issue, so I'm going to switch the component to i18n to catch somebody's opinion there.

#6 @sabernhardt
10 months ago

  • Focuses accessibility removed

The separate issue for fixing the repetitive link text and removing the excerpt_more hook is on GitHub:
https://github.com/WordPress/gutenberg/issues/55026

Regarding the current translatable strings:

  • Two German translations used a non-breaking space, and some languages have three periods instead of the ellipsis.
  • The text inside the links for the editor and the front end do not always match (for example, in French).

#7 @swissspidy
5 months ago

  • Focuses coding-standards removed
  • Milestone Awaiting Review deleted
  • Resolution set to reported-upstream
  • Status changed from new to closed

The space issue has since been fixed in Gutenberg, see https://github.com/WordPress/gutenberg/commit/8ef6e404f1de2ca22e3921c8e454e4335c843143

Note that this whole file is coming from GB, so if there are any more issues in there, please report them on the Gutenberg repo.

Note: See TracTickets for help on using tickets.