Make WordPress Core

Opened 5 weeks ago

Closed 10 days ago

#60780 closed defect (bug) (duplicate)

Twenty Twenty :- Button block having issue with letter spacing

Reported by: nidhidhandhukiya's profile nidhidhandhukiya Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.4.3
Component: Bundled Theme Keywords: has-patch needs-testing
Focuses: Cc:

Description

Steps to reproduce the issue :-

  1. Activate Twenty Twenty theme.
  2. Choose Button block.
  3. Add text.
  4. Now change the letter spacing.

You can able to see there is no difference in letter spacing in editor and front side both.

I have attached video for better understanding.
Video URL :- https://share.cleanshot.com/mpT4l41VskS7J26DB23b

Attachments (2)

60780.patch (1.8 KB) - added by nidhidhandhukiya 5 weeks ago.
60780.2.patch (2.6 KB) - added by shailu25 4 weeks ago.
Updated Patch

Download all attachments as: .zip

Change History (6)

#1 @poena
5 weeks ago

  • Keywords changes-requested has-patch added
  • Summary changed from Twenty Twenty :- Button block having issue with line-height to Twenty Twenty :- Button block having issue with letter spacing

Hi!

Thank you for reporting this issue. I can reproduce the problem.
I updated the ticket title to reflect that the problem is with the letter spacing.

I would like to make the following change request:

The default letter spacing must remain the same, otherwise, it changes the button style on live sites where the user (site owner) has not changed the setting.
Removing the letter spacing would mean the theme no longer matches the design that the designer created specifically for this theme.

@shailu25
4 weeks ago

Updated Patch

#2 @shailu25
4 weeks ago

  • Keywords changes-requested removed

Updated Patch as per suggested in above comment.

  • In Button block if no letter spacing is selected, it will take default letter spacing.
  • In Button block if letter spacing is selected, then it will add selected letter spacing.

#3 @poena
2 weeks ago

  • Keywords needs-testing added
  • Milestone changed from Awaiting Review to 6.6

Test Report

This report validates that the indicated patch addresses the issue.

Patch tested: https://core.trac.wordpress.org/attachment/ticket/60780/60780.2.patch

Environment

  • WordPress: 6.6-alpha-57778-src
  • PHP: 7.4.30
  • Server: nginx/1.23.1
  • Database: mysqli (Server: 8.0.36 / Client: mysqlnd 7.4.30)
  • Browser: Chrome 123.0.0.0
  • OS: macOS
  • Theme: Twenty Twenty 2.6
  • MU Plugins: None activated
  • Plugins:
    • Test Reports 1.1.0

Actual Results

  • ✅ Issue resolved with patch.

The default letter spacing is preserved, the letter spacing options on the buttons block and button block work in the editor and the front.

#4 @sabernhardt
10 days ago

  • Milestone 6.6 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #58024.

Thanks for updating the patch and testing it, but we already had a ticket and patch for the letter-spacing. 58204.2.patch does not include the .editor-styles-wrapper class, and that works with or without the iframe.

Note: See TracTickets for help on using tickets.