Make WordPress Core

Opened 8 weeks ago

Last modified 8 weeks ago

#60945 new defect (bug)

"Quick Edit" in Posts and Pages doesn't work in 6.5

Reported by: nelchee's profile nelchee Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version: 6.5
Component: Quick/Bulk Edit Keywords: needs-testing-info
Focuses: Cc:

Description

In Posts or Pages list, I click on the "Quick Edit" link under the post name.
The post disappears from the list (the entire row in the table is gone).
I refresh the page and the post is back on the list.

No matter how many times I tested it, it always happens exactly as described.

My Pages list has a few columns form other plugins (AIOSEO and Search Exclude), but the Posts doesn't have any aside from the default WordPress columns.

Change History (3)

#1 follow-up: @krupajnanda
8 weeks ago

  • Keywords needs-testing-info needs-screenshots added

Hi @nelchee

Thank you for opening a ticket.

I tried to replicate the same issue with the default WordPress environment set up and I am unable to reproduce the issue.

Could you please share some information about the test environment, test steps your following and visual for the same? This will help in replicating the issue.

#2 in reply to: ↑ 1 @nelchee
8 weeks ago

Thank you for your interest @krupajnanda, I appreciate it.

Unfortunately it's not a test environment, it's my live website :( So I'm not able to do the usual debugging thing of turning off every single plugin, etc. The site gets a lot of traffic. And replicating the entire staging site also seems like quite a lot of effort for what is an inconvenience that I can get around.

I don't know how long this has been going on, I only noticed today. I updated to 6.5 yesterday.
I also updated a SEO plugin yesterday, but upon deactivating it the bug still persists.
I also deactivated Search Exclude, and that one didn't have an effect either.
I don't know what other plugin could affect the Posts and Pages interface.

I recorded the video of the problematic behavior: https://drive.google.com/file/d/12G6njZ6Q1VrPnfk45-4ZuzwYD7eQqdVj/view?usp=sharing

You can see how post rows disappear when I click on the link. After a few tries I refresh the page and the posts are back on the list. I refreshed twice during the video.

I don't know what other information I can provide to make this replicable. There is quite a few plugins on my live site, but I don't know which of them may be relevant.

#3 @sabernhardt
8 weeks ago

  • Component changed from General to Quick/Bulk Edit
  • Keywords needs-screenshots removed

Hi!

Have you tried clearing cache (browser cache plus any caching from plugins or from your hosting account)?

When clicking the Quick Edit button, it should hide the table row and then print and show the Quick Edit form. In the video, the script hides the row, and it might print the form, but the form does not display.

If clearing all caches does not solve it, could you check the browser console for errors?

Note: See TracTickets for help on using tickets.