Make WordPress Core

Opened 7 weeks ago

Closed 5 weeks ago

Last modified 5 weeks ago

#60980 closed defect (bug) (fixed)

Fix get_item_features() in class-avif-info.php

Reported by: yguyon's profile yguyon Owned by: adamsilverstein's profile adamsilverstein
Milestone: 6.5.3 Priority: normal
Severity: normal Version: 6.5
Component: Media Keywords: has-unit-tests has-patch commit fixed-major dev-reviewed
Focuses: Cc:

Description

Change History (14)

This ticket was mentioned in PR #6379 on WordPress/wordpress-develop by @yguyon.


7 weeks ago
#1

Import upstream fix from libavifinfo to Wordpress.

Trac ticket: https://core.trac.wordpress.org/ticket/60980

Follow-up of https://github.com/WordPress/wordpress-develop/pull/4612.

@yguyon commented on PR #6379:


7 weeks ago
#2

@adamsilverstein FYI

This ticket was mentioned in Slack in #core-media by antpb. View the logs.


7 weeks ago

#4 @audrasjb
7 weeks ago

  • Milestone changed from Awaiting Review to 6.5.3
  • Version changed from trunk to 6.5

Thanks for the ticket and welcome to WordPress Core Trac,

Moving this bugfix to milestone 6.5.3 since it was introduced in 6.5/[57524].

This ticket was mentioned in Slack in #core-media by antpb. View the logs.


6 weeks ago

#6 @adamsilverstein
6 weeks ago

  • Keywords commit added
  • Owner changed from yguyon to adamsilverstein

Thanks for the fix @yguyon - looks good. Thanks especially for the tests and additional test image to reproduce the issue.

Moving this bugfix to milestone 6.5.3 since it was introduced in 6.5/[57524].

Thanks @audrasjb - I guess a small fix like this is worth back porting to 6.5?

This ticket was mentioned in Slack in #core by jorbin. View the logs.


6 weeks ago

#8 @jorbin
6 weeks ago

I guess a small fix like this is worth back porting to 6.5?

Yes, especially since it includes automated tests and prevents a fatal error.

This ticket was mentioned in Slack in #core by jorbin. View the logs.


5 weeks ago

#10 @adamsilverstein
5 weeks ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 58049:

Media: fix potential error in class-avif-info.php::get_item_features().

Import upstream fix from libavifinfo, correcting a potential fatal error.

Props yguyon.
Fixes #60980.

#11 @adamsilverstein
5 weeks ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

Reopening for backport consideration.

#12 @jorbin
5 weeks ago

  • Keywords fixed-major dev-reviewed added

[58049] looks good to backport.

#13 @adamsilverstein
5 weeks ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In 58050:

Media: fix potential error in class-avif-info.php::get_item_features().

Import upstream fix from libavifinfo, correcting a potential fatal error.

Reviewed by jorbin.
Merges [58049] to the 6.5 branch.

Props yguyon.
Fixes #60980.

Note: See TracTickets for help on using tickets.