Make WordPress Core

Opened 4 weeks ago

Closed 3 weeks ago

Last modified 3 weeks ago

#61098 closed defect (bug) (fixed)

phpcs error in wp-includes > capabilities.php line 1093

Reported by: dhruvang21's profile dhruvang21 Owned by: sergeybiryukov's profile SergeyBiryukov
Milestone: 6.6 Priority: normal
Severity: normal Version:
Component: Role/Capability Keywords: has-patch needs-testing needs-testing-info
Focuses: coding-standards Cc:

Description

If control structure block found as the only statement within an "else" block. Use elseif instead.phpcs

Change History (7)

This ticket was mentioned in Slack in #core-test by ankit-k-gupta. View the logs.


4 weeks ago

#3 @Ankit K Gupta
4 weeks ago

  • Keywords needs-testing needs-testing-info added

Thank you, @dhruvang21, for the report and PR. This ticket was discussed during this week's Test Team Triage Session. Could you provide the steps to test this fix and issue? This will greatly assist contributors in easily testing the fix.

#4 @dhruvang21
4 weeks ago

@ankit-k-gupta the issue is shown in the given screenshot https://www.awesomescreenshot.com/image/47850531?key=0abb0d1d7d0554d6fc35a906c2087273

and to test this fix you can run the phpcs checker command

#5 @SergeyBiryukov
3 weeks ago

  • Milestone changed from Awaiting Review to 6.6

#6 @SergeyBiryukov
3 weeks ago

  • Owner set to SergeyBiryukov
  • Resolution set to fixed
  • Status changed from new to closed

In 58099:

Coding Standards: Remove extra conditional in is_super_admin().

Follow-up to [12612].

Props dhruvang21, ankit-k-gupta, audrasjb.
Fixes #61098.

@SergeyBiryukov commented on PR #6459:


3 weeks ago
#7

Thanks for the PR! Merged in r58099.

Note: See TracTickets for help on using tickets.