Make WordPress Core

Opened 5 weeks ago

Last modified 5 weeks ago

#61211 new enhancement

List minimum version required when showing plugins that are "Incompatible with your version of WordPress"

Reported by: jeffpaul's profile JeffPaul Owned by:
Milestone: Awaiting Review Priority: low
Severity: normal Version:
Component: Plugins Keywords: needs-patch
Focuses: Cc:

Description

I happened to be testing something using WordPress 5.9.9 and went to add a plugin, in the example screenshot Gutenberg is the example here, and saw the standard "This plugin doesn’t work with your version of WordPress. Please update WordPress." and "Incompatible with your version of WordPress" error messaging on the plugin card (I'll leave aside the fact that double messaging here is probably not necessary).

The item that would be helpful alongside the error messaging is the minimum version of the plugin that is required. In the case of the Gutenberg example I have to click "More Details" to get the plugin modal overlay showing that at the current day Gutenberg "Requires WordPress Version: 6.4 or higher". Having that 6.4 version noted within the plugin card would be helpful context. Perhaps updating the first error message to something more like "This plugin doesn’t work with your version of WordPress. Please update WordPress 6.4 or newer." would be a more helpful error message.

Attachments (1)

Gutenberg-plugin-card.png (73.2 KB) - added by JeffPaul 5 weeks ago.
Gutenberg plugin card on WordPress version 5.9.9

Download all attachments as: .zip

Change History (3)

@JeffPaul
5 weeks ago

Gutenberg plugin card on WordPress version 5.9.9

#1 @jorbin
5 weeks ago

As it's possible for a plugin to have its minimum set to a version that is not supported by WordPress, I worry that this could come across as WordPress encouraging a user to update from one unsupported version to another.

#2 @JeffPaul
5 weeks ago

@jorbin fair; presumably we could have a lower and upper bounds for what is presented and if the plugin reports outside that range then we show the more generic non-version noted text?

Note: See TracTickets for help on using tickets.