WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#6243 closed defect (bug) (fixed)

swfupload doesn't work well with lighttpd

Reported by: nbachiyski Owned by:
Milestone: 2.5 Priority: high
Severity: major Version:
Component: General Keywords: has-patch swfupload lighttpd lighty 400
Focuses: Cc:

Description

When trying to upload a file, swfupload gets HTTP error 400. There is more information about the issue in the swfupload forums.

The current degradation mechanism takes into account only client-side issues and if the browser is capable of loading swfupload this will be the method used. The attached patch tells the degrade script if the current webserver is lighty, so that it can degrade gracefully. The current loaded handler for swfupload had to be removed, because the degrade script does essentially the same and the custom hadnler used to override the degrade plugin.

Attachments (2)

degrade-swfupload-when-lighty.diff (2.8 KB) - added by nbachiyski 6 years ago.
degrade-swfupload-when-lighty-before-150.diff (4.0 KB) - added by nbachiyski 6 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 andy6 years ago

  • Resolution set to wontfix
  • Status changed from new to closed

Evidently the issue is fixed in lighttpd 1.5:

http://trac.lighttpd.net/trac/ticket/1017

comment:2 lloydbudd6 years ago

  • Milestone 2.5 deleted

comment:3 nbachiyski6 years ago

  • Milestone set to 2.5
  • Resolution wontfix deleted
  • Status changed from closed to reopened

We have to fix this in some way, since still most of the people are using 1.4.x and not 1.5. Here is a quote about 1.5 from lighttpd's download page:

No. We don't have a release date for it. Especially not with all the big changes going on.

Attached is a new patch, which degrades to the old upload form only if it is lighttpd < 1.5.0 and shows an informational message to tell users why they can't use the flash uploader and to upgrade if they want to.

comment:4 nbachiyski6 years ago

  • Keywords has-patch added

comment:5 ryan6 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [7406]) Degrade flash upload if the server is lightttpd < 1.5. Props nbachyski. fixes #6243

comment:6 ryan6 years ago

(In [7407]) Typo fix. see #6243

Note: See TracTickets for help on using tickets.