WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#7053 closed enhancement (duplicate)

Give child themes the ability to override parent theme template files on a per-file basis

Reported by: dnusim Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.6
Component: Template Keywords: 2nd-opinion
Focuses: Cc:

Description

Specifying a parent Theme in your Theme's style.css will make your Theme inherit all of the template files from that Theme — meaning that any template files in the child Theme's directory will be ignored.

It would have been great if a child Theme could have the ability to override the parent Theme's template files - only inheriting template files that don't exist within the child Theme's directory.

This change would make it easier to customize a theme while still being able to take advantage of updates to the parent Theme without losing your beloved custom hacks.

Change History (5)

comment:1 thee176 years ago

  • Resolution set to invalid
  • Status changed from new to closed

comment:2 DD326 years ago

thee17 do you have a reason to close this as invalid?

comment:3 DD326 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened
  • Version set to 2.6

Reopening the ticket unless a reason to close it is brought up.

I'd expect it to inherit all parent theme templates, And any template files in the child themes folder would also be present, with any templates there taking precedence of the parent theme.. (If that makes sense)

comment:4 ionfish6 years ago

  • Resolution set to duplicate
  • Status changed from reopened to closed

Duplicate of #7086.

comment:5 thee176 years ago

  • Milestone 2.9 deleted
Note: See TracTickets for help on using tickets.