Make WordPress Core

Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#7200 closed defect (bug) (duplicate)

Wrong url when page navigation

Reported by: a.verdeja Owned by:
Milestone: Priority: high
Severity: major Version:
Component: General Keywords: navigation, static frontpage
Focuses: Cc:

Description

When you have the following configuration

  • Static frontgpage
  • "Pretty permalinks

and click on previous entries, the url will be http://mydomain.com/blog/page/2/, but it should be http://mydomain.com/page/2/

This can be corrected with the following code in the .htaccess file:

RedirectMatch /blog/page/(.*)$ http://mydomain.com/page/$1/

The problem is then that you cann't have a paginated -static- front page

Change History (2)

#1 @mtekk
14 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

I've ran into this before...

In most cases you'd actually want the url to be http://mydomain.com/blog/page/2 but it returns a 404 or some seeming random page.

It looks like this is already being taken care of in #6603, I'm closing this as a duplicate for now.

#2 @mtekk
14 years ago

  • Milestone 2.7 deleted
Note: See TracTickets for help on using tickets.