WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 5 years ago

#7724 closed defect (bug) (fixed)

Install error with 2.6.1 or 2.6.2 "WordPress database error Table 'wpmu.wp_options' doesn't exist"

Reported by: rdworth Owned by:
Milestone: 2.7 Priority: high
Severity: blocker Version: 2.6.1
Component: General Keywords: install database error 2.6.1 2.6.2 table doesn't exist
Focuses: Cc:

Description

The install fails with a database error when run on a new (empty) database.

Steps to reproduce

  1. Create new (empty) database
  1. Clean copy of WordPress 2.6.1 or 2.6.2
  1. Create wp-config.php (through wizard, or manually)
  1. From /wp-admin/setup-config.php?step=2 click 'Run the install' or navigate to /wp-admin/install.php

Result

2.6.1

WordPress database error Table 'wpmu.wp_options' doesn't exist for query INSERT
INTO wp_options (option_name, option_value, autoload) VALUES ('cron',
'a:2:{i:...2;}', 'yes') made by add_option

WordPress database error Table 'wpmu.wp_options' doesn't exist for query INSERT
INTO wp_options (option_name, option_value, autoload) VALUES ('auth_salt',
'Ko!oT4Gk#)5t', 'yes') made by add_option

2.6.2

WordPress database error Table 'wpmu.wp_options' doesn't exist for query INSERT
INTO wp_options (option_name, option_value, autoload) VALUES ('cron',
'a:2:{i:...2;}', 'yes') made by add_option

WordPress database error Table 'wpmu.wp_options' doesn't exist for query INSERT
INTO wp_options (option_name, option_value, autoload) VALUES ('random_seed',
'1234567890abcdef1234567890abcdef', 'yes') made by add_option

WordPress database error Table 'wpmu.wp_options' doesn't exist for query INSERT
INTO wp_options (option_name, option_value, autoload) VALUES ('auth_salt',
'jlIBZDb&xo2A', 'yes') made by add_option

This seems to be caused by [8514] which is related to #7372

See attached for proposed patch.

Attachments (2)

wp-includes_update.patch (516 bytes) - added by rdworth 6 years ago.
patch_wp_includes_update_php_8941.diff (700 bytes) - added by tott 6 years ago.
patch wp-includes/update.php (rev 8941)

Download all attachments as: .zip

Change History (8)

rdworth6 years ago

comment:1 Viper007Bond6 years ago

Just a note: his database name is "wpmu" so don't get all confused like I did.

comment:2 rdworth6 years ago

Yes, good note. I first found the issue in WordPress MU and traced it back to WordPress. Seems I never renamed the database during testing.

comment:3 tott6 years ago

checked against trunk r8941
problem still exists. provided patch does not solve the whole problem attaching additional patch against r8941

tott6 years ago

patch wp-includes/update.php (rev 8941)

comment:4 MichaelH5 years ago

Just linking to related threads in Forum: http://wordpress.org/tags/wp_options

comment:5 ryan5 years ago

  • Milestone changed from 2.8 to 2.7

comment:6 ryan5 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [9244]) Don't schedule update events while installing. Props rdworth and tott. fixes #7724

Note: See TracTickets for help on using tickets.