WordPress.org

Make WordPress Core

Opened 12 years ago

Closed 12 years ago

#10899 closed defect (bug) (duplicate)

FTP password doesn't work if it contains an apostrophe

Reported by: ChadCloman Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.8.4
Component: Upgrade/Install Keywords:
Focuses: Cc:

Description

When automatically updating a plugin, I was asked for my FTP credentials. The FTP login always failed. I tried multiple times to get it to work, on multiple occasions.

My password happened to include an apostrophe. I changed the password so that it no longer had the apostrophe. Then when I re-tried the FTP update, it worked.

Note that it's not only the plugin update FTP that didn't work. There were other occasions where the WP admin pages asked for FTP credentials, and none of them worked with the apostrophe.

I haven't looked through the code, but I'm assuming there's a generic input function that escapes special characters like apostrophes, and that this is why it didn't work.

WordPress 2.8.4, Windows XP, Firefox 3.5.3

Change History (1)

#1 @dd32
12 years ago

  • Component changed from General to Upgrade/Install
  • Milestone Unassigned deleted
  • Resolution set to duplicate
  • Status changed from new to closed

See: [11808] Strip slashes from POST data in request_filesystem_credentials(), props dd32, fixes #10567

Note: See TracTickets for help on using tickets.