WordPress.org

Make WordPress Core

Opened 11 years ago

Closed 10 years ago

Last modified 22 months ago

#11532 closed defect (bug) (fixed)

Data returned by plugins API is double UTF-8 encoded

Reported by: sirzooro Owned by: ryan
Milestone: WordPress.org Priority: high
Severity: normal Version: 2.9
Component: WordPress.org Site Keywords: needs-patch
Focuses: Cc:

Description

Data returned by plugins API is double UTF-8 encoded. As I recall, this worked in the past, so something has changed recently. Results are the same on WP 2.8.6 and 2.9.

You can test this by searching for "nasza" via Plugins/Add New in WP - in results you should get only one plugin, "Nasza Klasa - Wizytówka". Its name, description and author's name are double utf-8 encoded now.

Change History (8)

#1 @hakre
11 years ago

  • Component changed from WordPress.org to Charset
  • Owner changed from ryan to hakre
  • Version set to 2.9

I can confirm this for current trunk as well, was able to reproduce. Change it to charset because this might be a problem in core-code and not with the wordpres.org website.

Nasza Klasa - Wizytówka Plugin on WordPress Org

Same for the install thickbox as well, not only the search listing.

#2 @hakre
11 years ago

  • Priority changed from normal to high

#3 @hakre
11 years ago

Related: #9739

#4 follow-up: @hakre
11 years ago

  • Milestone changed from WordPress.org site to 3.0

Related: #11567

#5 in reply to: ↑ 4 @westi
11 years ago

  • Milestone changed from 3.0 to WordPress.org site

Replying to hakre:

Related: #11567

Please leave the milestone for WordPress.org api issues set to WordPress.org site as changes made there are version independent.

#6 @dd32
11 years ago

  • Component changed from Charset to WordPress.org
  • Owner changed from hakre to ryan

#7 @mdawaffe
10 years ago

  • Resolution set to fixed
  • Status changed from new to closed

Looks good to me now.

This ticket was mentioned in Slack in #core-editor by mrioa. View the logs.


22 months ago

Note: See TracTickets for help on using tickets.