WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#12003 closed defect (bug) (duplicate)

Explicit teasers with <!--more--> don't work in RSS feeds

Reported by: stickboy Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.9.1
Component: Feeds Keywords: close
Focuses: Cc:

Description

I have my WordPress 2.9.1 installation configured to show full text for the syndication feeds. Occasionally I'll make a post containing spoilers to some movie/television show/etc., and I use the <!--more--> tag to create a teaser for the page so that readers need to click the link before revealing anything.

This works fine for my weblog's main page, but it doesn't work for my RSS feed, which continues to show the entirety of my post. The generated RSS XML has:

<content:encoded><![CDATA[
<p>teaser text</p>
<p><span id="more-190"></span></p>
<p>rest of content</p>
]]></content:encoded>

I think this might have worked in older versions of WP, and from the comments to http://core.trac.wordpress.org/ticket/1392 it sounds like this isn't the way it's meant to work.

Change History (2)

comment:1 scribu4 years ago

  • Keywords close added

As I remember, there was a big debate on what the "full text" option should actually do. It was settled that it should display the full content of the post, ignoring the <!-- more --> tag.

See #2582

comment:2 scribu4 years ago

  • Milestone Unassigned deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Closing this as duplicate of #6680.

Note: See TracTickets for help on using tickets.