WordPress.org

Make WordPress Core

Opened 11 years ago

Closed 11 years ago

#12697 closed defect (bug) (duplicate)

Navigation menu admin doesn't allow for feminine form

Reported by: xibe Owned by: nbachiyski
Milestone: Priority: normal
Severity: normal Version: 3.0
Component: I18N Keywords:
Focuses: Cc:

Description

The sidebar for /wp-admin/nav-menus.php uses the following code for its "Add..." metaboxes labels: "Add an Existing %s", where %s can be any form post_type.

This does not work for some languages other than English. For instance in French, while Article (Post) is masculine, Page and Catégorie are feminine, and therefore need specific wordings.

Guilty foreach loops are to be found in both wp_nav_menu_post_type_metaboxes() and wp_nav_menu_taxonomy_metaboxes().

Change History (3)

#1 @ptahdunbar
11 years ago

  • Cc trac@… added

So the $post_type->singular_label needs to change or are you suggesting the entire phase be changed all together? What would be more appropriate?

#2 @nacin
11 years ago

  • Status changed from new to assigned

I think we need something like $pt->singular_label_add_new for both taxonomies and custom post types, which would default to sprintf( __( 'Add New %s', $pt->singular_label ) ).

We would probably need label_add_new as well, for Add New Posts (versus Add New Post). Not sure if we use the plural variant in core anywhere though. If that's the case, we could just go with add_new_label as being the singular form.

We've been keeping the i18n requirements in the back of our mind for a while now. Assigning for Nikolay for a full review.

#3 @nacin
11 years ago

  • Milestone 3.0 deleted
  • Resolution set to duplicate
  • Status changed from assigned to closed

Closing this as a duplicate of #12968.

Note: See TracTickets for help on using tickets.