WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#16013 closed defect (bug) (worksforme)

has_archive breaks wp-admin pagination

Reported by: ejdanderson Owned by: nacin
Milestone: Priority: normal
Severity: normal Version: 3.1
Component: Posts, Post Types Keywords:
Focuses: Cc:

Description

When defining a custom post type with the has_archive argument set to true, backend pagination of that custom post type no longer works properly. Setting the Show On Screen number also appears to be broken with this argument, making it impossible, outside of searching or ordering to reach some posts.

Change History (7)

#1 @nacin
7 years ago

  • Milestone changed from Awaiting Review to 3.1
  • Owner set to nacin
  • Status changed from new to reviewing

#2 @ejdanderson
7 years ago

The show on screen ability is related to ticket:15970 it looks like, not the has_archive argument.

#3 in reply to: ↑ description @SergeyBiryukov
7 years ago

Replying to ejdanderson:

When defining a custom post type with the has_archive argument set to true, backend pagination of that custom post type no longer works properly.

Can't reproduce on 3.1-RC1-17163. What are the exact steps to manifest it?

#4 @nacin
7 years ago

Couldn't reproduce either.

Please provide the code.

#5 @nacin
7 years ago

  • Keywords reporter-feedback added; custom post type has_archive removed

#6 @ejdanderson
7 years ago

  • Resolution set to worksforme
  • Status changed from reviewing to closed

My mistake, the issue at hand came from an addon that was left in the directory which was attempting to customize archive templates based on the post type.

#7 @ocean90
7 years ago

  • Keywords reporter-feedback removed
  • Milestone 3.1 deleted
Note: See TracTickets for help on using tickets.