WordPress.org

Make WordPress Core

Opened 10 years ago

Closed 7 years ago

Last modified 7 years ago

#17261 closed defect (bug) (fixed)

Ctrl(+shift)+tab don't work when tinyMCE has focus

Reported by: aaroncampbell Owned by: azaozz
Milestone: 3.9 Priority: normal
Severity: major Version: 3.2.1
Component: TinyMCE Keywords: has-patch
Focuses: Cc:

Description

At first I thought this was a DFW bug, but it seems to be tinyMCE related as it affects the regular editor.

If you are focused in tinyMCE ctrl+tab and ctrl+shift+tab don't work as expected (switching you to the next/previous tab).

  • In Firefox 4 on Ubuntu:
    • ctrl+tab does nothing
    • ctrl+shift+tab moves focus to the title box
  • In Firefox 4 on Windows 7
    • ctrl+tab does nothing
    • ctrl+shift+tab moves focus to the title box
    • tab and shift+tab do nothing as well (rather than switch focus)
  • In IE 9
    • Everything works as expected
  • In Opera 11.10 on Windows
    • The first ctrl+tab or ctrl+shift+tab moves focus and the second switches tabs
  • In Safari 5.0.5 on Windws
    • ctrl+tab works as expected
    • ctrl+shift+tab does nothing
  • In Chrome on both Windows and Ubuntu
    • Everything works as expected

Attachments (1)

17261.diff (3.4 KB) - added by solarissmoke 10 years ago.
Remove tabfocus TinyMCE plugin

Download all attachments as: .zip

Change History (10)

#1 @solarissmoke
10 years ago

The issue is with the tabfocus plugin - disable that and it works fine in all browsers. Probably worth reporting upstream (although I'm not sure if browser implementations are also buggy).

#2 @azaozz
10 years ago

I think we can actually remove the tabfocus TinyMCE plugin for the exact same reasons listed in this ticket: it works inconsistently in different browsers and versions. Also we have some JS to move the focus from the title to the editor which is the more important part.

Additionally I looked at the "tabbing" through WordPress admin and it seems it works much better with tabindex=... removed everywhere (but that's probably for another ticket).

@solarissmoke
10 years ago

Remove tabfocus TinyMCE plugin

#3 @solarissmoke
10 years ago

  • Keywords has-patch added; needs-patch removed

Just tried to get it to do what it is supposed to - i.e., move focus to major-publishing-actions when you press tab - it doesn't in Firefox 4, Opera 11 and IE 9 :S.

#4 @DrewAPicture
9 years ago

  • Version set to 3.2.1

I can confirm this on Firefox 8 on 3.2.1 and latest trunk. Marking as 3.2.1 unless somebody can test earlier.

#6 @grahamarmfield
7 years ago

  • Cc graham.armfield@… added

Can confirm that everything works as expected in IE10 on Windows 7 laptop, but I'm still experiencing the problem in Firefox 25 on all my Windows machines. This is a bit of a showstopper for anyone who relies on keyboard operation to update their blog/website.

I'm not sure if the fix for this has ever been committed.

#7 @grahamarmfield
7 years ago

  • Severity changed from normal to major

#8 @azaozz
7 years ago

  • Owner set to azaozz
  • Resolution set to fixed
  • Status changed from new to closed

In 27034:

TinyMCE: do not run preventDefault() on the tab key when Ctrl, Alt or Command key is also pressed. Ctrl + Tab is used to switch between browser tabs. See #24067, fixes #17261.

#9 @ocean90
7 years ago

  • Milestone changed from Awaiting Review to 3.9
Note: See TracTickets for help on using tickets.