WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 15 months ago

#17802 closed defect (bug) (fixed)

In gallery sorting, the Order header doesnt align with the Order textbox

Reported by: dd32 Owned by:
Milestone: 3.5 Priority: normal
Severity: normal Version: 3.1
Component: Media Keywords: has-patch ui-feedback
Focuses: Cc:

Description (last modified by dd32)

As reported by rasheed as part of #17790, the Order textbox on the Gallery Sorting screen isn't aligned to the header, instead, it's shown under Actions.

This page is a bit strange, in the sense that the header of the table is a table, whereas the rows are divs.

for how it looks in RTL, see this file, pretty much the same in ltr, just fliped around.. (Note, It's not RTL specific)

Attachments (2)

media-css-ticket-17802.diff (10.1 KB) - added by AndrewFrazier 3 years ago.
17802.1.diff (1.8 KB) - added by designsimply 2 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 dd323 years ago

  • Description modified (diff)

comment:2 AndrewFrazier3 years ago

  • Keywords has-patch added

If you change the width of the '#media-upload th.actions-head' and '#media-upload th.order-head' in media.css and media.dev.css down to 10% each the headers then appear above the columns that they relate to.

This patch makes that change.

comment:3 designsimply2 years ago

Here's another take on it, which is to keep the table header widths as is and make the div column widths match. It uses 19841.diff from #19841 by mitchoyoshitaka with one small additional margin change.

designsimply2 years ago

comment:4 SergeyBiryukov2 years ago

Closed #20654 as a duplicate.

comment:5 SergeyBiryukov2 years ago

  • Component changed from Administration to UI

comment:6 SergeyBiryukov2 years ago

  • Keywords ui-feedback added

comment:7 follow-up: tomauger2 years ago

  • Cc tomaugerdotcom@… added

At the end of the day, probably the right thing to do is to change the sortables to TRs and make sure everything sits within the table structure set out by the header. That's the only way we can be sure the columns will align in all l10n situations where the header text or the action text may expand.

I'll work up a patch in the next few days. Looks like you can do ui-sortables on TR elements as long as you include a TBODY.

comment:8 in reply to: ↑ 7 azaozz2 years ago

Replying to tomauger:

As far as I remember this wasn't working well in earlier versions of UI. When you're attempting it, please test on a native IE7 and IE8.

comment:9 sabreuse15 months ago

  • Component changed from UI to Media
  • Milestone changed from Awaiting Review to 3.5
  • Resolution set to fixed
  • Status changed from new to closed

Superseded by media/gallery changes in 3.5

Note: See TracTickets for help on using tickets.