WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 11 months ago

Last modified 11 months ago

#19140 closed defect (bug) (worksforme)

Save Menu Forces Sub-Menus (Child Menus) Back To Parent Menus in IE 9.0

Reported by: webby 2 Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.2.1
Component: Menus Keywords: reporter-feedback
Focuses: Cc:

Description

The following issue appears in Internet Explorer 9.0.8112.16421 (current version).

In Appearance->Menus for both primary and secondary menus, when you try to define a sub-menu by drag-n-dropping to the right in the menu definition box, it shows indented properly. However, when you click Save Menu, all sub-menus return to being parent menus.

The only way to get the sub-menus to work was to edit them in another browser. In this case, I used Internet Explorer 7.0.5730.11 and it worked properly.

Change History (8)

comment:1 @nacin4 years ago

  • Keywords needs-testing added
  • Milestone changed from Awaiting Review to 3.3
  • Severity changed from major to critical

No plugins, default theme? Can someone else provide confirmation?

comment:2 @webby 24 years ago

Same problem with no plugins as with plugins.

Using the Weaver theme. Checked with the theme author who confirmed the theme would have no effect on this issue.

comment:3 @SergeyBiryukov4 years ago

Can't reproduce with the same IE version in 3.2.1 or 3.3 with or without Weaver theme.

My steps:

  1. Drag a child menu item to the right.
  2. Click "Save Menu". The menu hierarchy is displayed correctly.
  3. Reload the page or reopen it from the admin menu.
  4. The menu hierarchy is still displayed correctly.

comment:4 @MZAWeb4 years ago

Can't reproduce neither.

Same steps as Sergey. Also tried both updating an existing menu or creating a new one.

comment:5 @ocean904 years ago

  • Keywords reporter-feedback added; needs-testing removed
  • Milestone changed from 3.3 to Awaiting Review
  • Severity changed from critical to normal

Works for me too.

comment:6 @nick.foubert4 years ago

I'm having the exact same issue on Chrome 17.0.963.56, no active plugins, default theme, WP 3.3.1.

I then tried it with Safari 5.1.1 and had no issue creating a secondary menu. When I flipped back to Chrome, I just slightly dragged the menu item to the right (the one I successfully moved in Safari), then after I clicked 'Save Menu' the item was no longer a secondary menu.

comment:7 @chriscct711 months ago

  • Resolution set to worksforme
  • Status changed from new to closed

Can't reproduce on 3.3.1 and IE 9 (via emulator) and given the lack of other people with the same problem, I'm inclined to believe its some sort of environmental problem. Closing as worksforme unless the ticket gets more reports.

Last edited 11 months ago by chriscct7 (previous) (diff)

comment:8 @DrewAPicture11 months ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.