WordPress.org

Make WordPress Core

Opened 9 years ago

Closed 6 years ago

Last modified 6 years ago

#19383 closed defect (bug) (maybelater)

Hide post formats next to post titles if the active blog theme does not support post formats

Reported by: philiparthurmoore Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.1
Component: Post Formats Keywords: ux-feedback close
Focuses: Cc:

Description

If I'm using a theme that supports post formats—e.g. Twenty Eleven—then next to each title on wp-admin/edit.php I'm able to see not only the title name but also the post format that corresponds to its respective post.

If I switch to a theme that does not support post formats at all I am still able to see post formats associated with their respective posts.

This is not good for a few reasons:

  • Showing a post format next to a title while a theme that doesn't support post formats is active is confusing. "Why does my post have the word Image/Link/Status/Quote by it? What does that mean?"
  • There is no way to edit or remove a post format associated with a post when a theme that does not support post formats is active, so the labels are useless.

When a theme that does not support post formats is active those format labels should be hidden. The posts can of course still retain their formats in case a user switches back to a theme that supports theme, but otherwise they should be hidden.

Attachments (1)

twenty-eleven.png (125.9 KB) - added by philiparthurmoore 9 years ago.
Post format labels

Download all attachments as: .zip

Change History (15)

@philiparthurmoore
9 years ago

Post format labels

#1 in reply to: ↑ description @philiparthurmoore
9 years ago

When a theme that does not support post formats is active those format labels should be hidden. The posts can of course still retain their formats in case a user switches back to a theme that supports theme, but otherwise they should be hidden.

That should read "...back to a theme that supports them..."

#2 @philiparthurmoore
9 years ago

  • Cc philip@… added

#3 follow-ups: @nacin
9 years ago

This is by design.

The format is dictated by the content, not by the theme. As these formats are fixed and portable, a subsequent theme switch could provide for an additional format to be supported.

When editing a post of an unsupported format, you're able to keep that existing format. If anything, you should be able to choose any format, separated into a supported list and an unsupported one. Again, we're describing the content — it is up to the theme to act on the design.

#4 in reply to: ↑ 3 @DrewAPicture
9 years ago

  • Cc xoodrew@… added

Replying to philiparthurmoore:

  • Showing a post format next to a title while a theme that doesn't support post formats is active is confusing. "Why does my post have the word Image/Link/Status/Quote by it? What does that mean?"
  • There is no way to edit or remove a post format associated with a post when a theme that does not support post formats is active, so the labels are useless.

At the very least, there should be helper text in the Help tabs to explain what Post Formats are for the uninitiated. We shouldn't be assuming that users know anything about this feature out of the gate.

Replying to nacin:

This is by design.

The format is dictated by the content, not by the theme. As these formats are fixed and portable, a subsequent theme switch could provide for an additional format to be supported.

It seems like we're basing an awful lot on assumptions here.

Look at this from a User POV:

  • Your theme doesn't support Post Formats
  • You're seeing these labels on the Manage Posts screen and literally have no way to A) Know what their significance is and B) Edit/Remove them in any way.

When editing a post of an unsupported format, you're able to keep that existing format. If anything, you should be able to choose any format, separated into a supported list and an unsupported one.

Again, you're assuming these users

  • Already know what Post Formats are
  • Have a theme that supports them
  • Have a metabox on the editing screen
  • Know how to use them

Until Post Formats are more widely adopted by theme authors, we should be assuming that users don't know what they are and how they work. So displaying labels that go with an unsupported feature seems counter-productive and apt to cause confusion. I'll reiterate the need for helper text in the Help tabs concerning Post Formats.

Sorry, long reply.

#5 @DrewAPicture
9 years ago

  • Keywords ux-feedback added

#6 in reply to: ↑ 3 @philiparthurmoore
9 years ago

Replying to nacin:

The format is dictated by the content, not by the theme. As these formats are fixed and portable, a subsequent theme switch could provide for an additional format to be supported.

When editing a post of an unsupported format, you're able to keep that existing format. If anything, you should be able to choose any format, separated into a supported list and an unsupported one. Again, we're describing the content — it is up to the theme to act on the design.

A theme should not need to add post format support into its functions file just for the sake of a user being able to modify or remove a post format associated with a post. Post formats should only be supported by themes that intend to in some way use them in a way that's constructive to the theme (and user), otherwise they are nothing more than visual pollution on the Edit Post pages.

So it seems that the most sensible solution would be to hide those labels while retaining the post format data. If not that, then adding helper documentation close to the post format labels that explains to a user why they are there and why they cannot use them.

#7 @nacin
9 years ago

  • Version changed from 3.3 to 3.1

#8 @iseulde
7 years ago

  • Component changed from General to Post Formats

#9 follow-ups: @helen
7 years ago

Is it any better now that they're icons? I know there's still the base issue of the support piece, but just wondering.

#10 in reply to: ↑ 9 @DrewAPicture
7 years ago

  • Keywords close added

Replying to helen:

Is it any better now that they're icons? I know there's still the base issue of the support piece, but just wondering.

I think the icons suffice for now. We should look at improving the help text with the incoming PFUI plugin.

#11 in reply to: ↑ 9 ; follow-up: @philiparthurmoore
7 years ago

Replying to helen:

Is it any better now that they're icons? I know there's still the base issue of the support piece, but just wondering.

I am not sure if the following behavior is newish or not, but it appears to be more recent than when I first submitted this issue. The icons set makes it better visually but doesn't quite address the primary issue, which is control over post formats in themes that offer no support for post formats. This is what I see in 3.7-alpha-25000.

  1. I have a theme activated that supports two non-standard post formats: image and quote. When I create a new post, this is what I expect to see:

http://p-am.net/grabs/pf-standard-image-quote-1.jpg

  1. If I go to /wp-admin/edit.php and have posts with post formats that aren't supported by the theme present, this is what I see:

http://p-am.net/grabs/pf-test.jpg

  1. If I click Edit on a post that has a non-supported format (e.g. Post Format Test: Link), this is what I see under the Format tab:

http://p-am.net/grabs/pf-format-link-active.jpg

  1. If I choose another format for the post (e.g. Standard), and click save, this is the Format tab that then comes up:

http://p-am.net/grabs/pf-link-after-save.jpg

So right now there's a problem in interacting with post formats that aren't supported by a theme but associated with a post pre-theme switch.

I still feel the best bet is the one that's most consistent, which is either to always hide unsupported PF icons/text when a theme doesn't support it, or to always show PF icons/text, regardless of theme support, and allow users to remove/attach PF support to posts in themes that don't support a specific format. Both of those have drawbacks, but the current inconsistency in PF UI is very confusing.

#12 @wonderboymusic
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to maybelater
  • Status changed from new to closed

No one has taken any interest in a year. Please only reopen with a patch or proposed solution.

#13 in reply to: ↑ 11 @SergeyBiryukov
6 years ago

Replying to philiparthurmoore:

  1. I have a theme activated that supports two non-standard post formats: image and quote. When I create a new post, this is what I expect to see:

http://p-am.net/grabs/pf-standard-image-quote-1.jpg

Please attach images to the ticket in the future, otherwise it becomes confusing when they are no longer available.

#14 @philiparthurmoore
6 years ago

I was wondering why my server logs were showing this file missing all of a sudden. :-P Talk about a blast from the past.

I'll see if I can find the image and upload it directly to this ticket for posterity. Shouldn't be too difficult.

Note: See TracTickets for help on using tickets.