WordPress.org

Make WordPress Core

Opened 4 years ago

Last modified 4 months ago

#20888 reopened defect (bug)

RDF Feed validation problems.

Reported by: hootbah Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version: 3.3.2
Component: Feeds Keywords: has-patch needs-unit-tests
Focuses: Cc:

Description

The RDF feed produced by feed-rdf.php produced validation errors due to description either not encoded correctly or not wrapped in CDATA tags.

To reproduce view a RDF feed: http://en.blog.wordpress.com/feed/rdf/

To see the validation errors: http://validator.w3.org/feed/check.cgi?url=http%3A%2F%2Fen.blog.wordpress.com%2Ffeed%2Frdf%2F

Attached is a patch to fix this issue.

Attachments (2)

feed-rdf.php.patch (1.3 KB) - added by hootbah 4 years ago.
20888.patch (693 bytes) - added by stevenkword 4 months ago.
Refresh

Download all attachments as: .zip

Change History (9)

#1 @Latz
3 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #18056.

Hello hootbah,

thank you for your report. It's been a long time since you've reported. The problem has been fixed during working on a different ticket (ticket:18056])

This ticket was mentioned in IRC in #wordpress-dev by Latz_. View the logs.


3 years ago

#3 @TobiasBg
3 years ago

  • Milestone Awaiting Review deleted

#4 @ocean90
3 years ago

  • Keywords reporter-feedback needs-refresh added
  • Milestone set to Awaiting Review

I'm reopening this because the patch includes also a change to the description field which is not covered by #18056.

This sounds like we need some unit tests here to make sure all the other fields are good enough.

#5 @SergeyBiryukov
3 years ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

#6 @stevenkword
17 months ago

  • Keywords needs-unit-tests added; reporter-feedback removed

@stevenkword
4 months ago

Refresh

#7 @stevenkword
4 months ago

  • Keywords needs-refresh removed
Note: See TracTickets for help on using tickets.