WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 5 years ago

#21510 closed defect (bug) (fixed)

Use get_background_color() in _custom_background_cb()

Reported by: greenshady Owned by:
Milestone: 3.9 Priority: normal
Severity: normal Version: 3.4.1
Component: Customize Keywords: has-patch
Focuses: Cc:

Description

When themes add a default background color via the custom-background feature, it isn't shown until the user saves it in the admin. The issue is that the _custom_background_cb() uses get_theme_mod( 'background_color' ) instead of get_background_color(), which will handle the default.

The attached patch should correct this.

Attachments (1)

get_background_color.diff (458 bytes) - added by greenshady 8 years ago.

Download all attachments as: .zip

Change History (6)

#1 @Jayjdk
8 years ago

  • Cc kontakt@… added

#2 @ocean90
8 years ago

Related: #20448

#3 @obenland
8 years ago

  • Cc konstantin@… added

#4 @nacin
6 years ago

  • Component changed from Themes to Appearance

#5 @celloexpressions
5 years ago

  • Milestone changed from Awaiting Review to 3.9
  • Resolution set to fixed
  • Status changed from new to closed

Fixed in [27703].

Note: See TracTickets for help on using tickets.