WordPress.org

Make WordPress Core

#21852 closed defect (bug) (duplicate)

AJAX in custom fields is broken

Reported by: SergeyBiryukov Owned by:
Milestone: Priority: normal
Severity: major Version: 3.5
Component: UI Keywords: has-patch
Focuses: Cc:

Description

Since [21789].

Due to how wp-lists.js currently works, button class should be appended, not prepended.

Attachments (1)

21852.patch (872 bytes) - added by SergeyBiryukov 20 months ago.

Download all attachments as: .zip

Change History (6)

SergeyBiryukov20 months ago

comment:1 scribu20 months ago

Isn't this the same as #21829?

comment:2 SergeyBiryukov20 months ago

No, button IDs are unrelated here.

comment:4 azaozz19 months ago

We are removing colons from the class names in wp-lists.js and switching to data-*. Thinking best way to do this would be to move the whole class names to data-wp-lists="...", then we can use that attr for the selectors.

comment:5 SergeyBiryukov19 months ago

  • Milestone 3.5 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Agreed, closing as a duplicate of #21152 then.

Note: See TracTickets for help on using tickets.