WordPress.org

Make WordPress Core

Opened 9 years ago

Closed 7 years ago

#2272 closed defect (bug) (duplicate)

about box html translated to entities

Reported by: midrangeman Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.0
Component: Administration Keywords: has-patch
Focuses: Cc:

Description

I just tried to update the "About yourself" box on my user profile and found that the HTML I include was 'decomposed' (don't know what the proper term is) ... basically, the HTML was translated to text and the html brackets were converted to entities.

Attachments (1)

2272.diff (642 bytes) - added by davidhouse 8 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 skeltoac9 years ago

  • Milestone set to 2.1

comment:2 davidhouse9 years ago

  • Severity changed from normal to enhancement

In other words, we don't allow HTML in the profile pages.

comment:3 midrangeman8 years ago

  • Severity changed from enhancement to normal

It used to be allowed. All the profiles on my site currently have HTML in the profiles but now, when they are edited, they are screwed up.

If the HTML isn't going to be allowed in the profile, then update the edit function to strip html from the profile before saving it.

davidhouse8 years ago

comment:4 davidhouse8 years ago

  • Keywords bg|has-patch added

comment:5 matt8 years ago

  • Milestone changed from 2.1 to 2.2

comment:6 foolswisdom7 years ago

  • Keywords has-patch added; bg|has-patch removed
  • Milestone changed from 2.2 to 2.3

comment:7 rob1n7 years ago

It might be good to check if the user that's editing the about box has unfiltered_html or so on. But that might get complicated.

comment:8 markjaquith7 years ago

  • Milestone 2.3 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #3069

Note: See TracTickets for help on using tickets.