WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 20 months ago

#22969 closed defect (bug) (duplicate)

freedoms.php list has odd numbering

Reported by: bkerensa Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.2
Component: Administration Keywords: has-patch
Focuses: Cc:

Description

freedoms.php's list of freedoms is numbered in a odd way

Attachments (2)

freedoms.png (43.1 KB) - added by bkerensa 2 years ago.
screenshot showing defect
freedoms.diff (2.2 KB) - added by bkerensa 23 months ago.
Improvement to freedoms.php with bullets and actual freedoms that are verbatim of the freedoms the FSF lists.

Download all attachments as: .zip

Change History (15)

@bkerensa2 years ago

screenshot showing defect

comment:1 @bkerensa2 years ago

  • Cc bkerensa@… added

comment:2 @helen2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Not a defect - this is how the FSF defines the 4 freedoms, as 0 through 3: http://www.gnu.org/philosophy/free-sw.html

Duplicate: #19158

comment:3 @bkerensa2 years ago

Hi Helen,

Ahh thanks for pointing that out :) but on the other hand FSF does make their list with bullets which seems a bit less confusing. Has there been any consideration to just match their styling?

comment:4 @SergeyBiryukov2 years ago

  • Component changed from General to Administration
  • Version changed from trunk to 3.2

comment:5 follow-up: @nacin2 years ago

We could go to bullets, but would then still want to specifically specify "Freedom 0" and so forth.

It was a famous blog post from Mark Pilgrim called "Freedom 0" that was a true catalyst for WordPress's popularity. http://txfx.net/2005/01/08/missing-mark-pilgrim/

@bkerensa23 months ago

Improvement to freedoms.php with bullets and actual freedoms that are verbatim of the freedoms the FSF lists.

comment:6 @bkerensa23 months ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

comment:7 @bkerensa23 months ago

  • Keywords dev-feedback 2nd-opinion added

comment:8 @SergeyBiryukov23 months ago

  • Milestone set to Awaiting Review

comment:9 in reply to: ↑ 5 @bkerensa22 months ago

Replying to nacin:

We could go to bullets, but would then still want to specifically specify "Freedom 0" and so forth.

It was a famous blog post from Mark Pilgrim called "Freedom 0" that was a true catalyst for WordPress's popularity. http://txfx.net/2005/01/08/missing-mark-pilgrim/

Updated

comment:10 follow-up: @SergeyBiryukov22 months ago

I don't think we need to change anything here. Our text seems to be clearer and less redundant.

comment:11 in reply to: ↑ 10 @bkerensa22 months ago

Replying to SergeyBiryukov:

I don't think we need to change anything here. Our text seems to be clearer and less redundant.

Per comment number 5 all that is being changed is adding bullets and bringing it closer to the actual freedoms outlined by the Free Software Foundation. Why remix what the FSF has already written so well?

comment:12 @c3mdigital20 months ago

  • Keywords close added; dev-feedback 2nd-opinion removed

I don't think anything should be changed. We are stating the freedoms in our own unique way. The ol list starting at 0 respects the original freedoms and freedom 0 better. It's a developer thing, like an array index or count always starts at 0.

comment:13 @SergeyBiryukov20 months ago

  • Keywords close removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from reopened to closed

Duplicate of #19158.

Note: See TracTickets for help on using tickets.