WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#23010 closed defect (bug) (fixed)

In WebKit TinyMCE may remove all spans when merging nodes with backspace

Reported by: azaozz Owned by: azaozz
Milestone: 3.5.1 Priority: normal
Severity: normal Version: 3.5
Component: TinyMCE Keywords:
Focuses: Cc:

Description

To reproduce:

  • Make a test post with couple of paragraphs.
  • Add some text colors (to a word or whole sentence). The colors are added as <span style="color:..."> around the selected text.
  • At the end of the post, press Enter and then immediately press backspace.

At this point all text colors disappear. Looking at the html, all spans have been stripped from the content. Caused by the fix for WebKit quirk with backspace (WebKit inserts lots of junk when merging the nodes on backspace).

Attachments (1)

23010.patch (451.7 KB) - added by azaozz 7 years ago.

Download all attachments as: .zip

Change History (6)

#1 @azaozz
7 years ago

  • Milestone changed from 3.6 to 3.5.1

This was fixed upstream: https://github.com/tinymce/tinymce/commit/113bd1ceaef1e1de5f2fdf54633d58424817182c

This is related to #22766 and will fix it as well. Thinking we should backport that patch and update TinyMCE in 3.5.1 (moving to 3.5.1 milestone for consideration).

@azaozz
7 years ago

#2 @azaozz
7 years ago

23010.patch​ contains the latest git version of TinyMCE.

#3 @azaozz
7 years ago

In 23192:

TinyMCE: update to latest source including the WebKit backspace fix, see #23010

#5 @azaozz
7 years ago

  • Owner set to azaozz
  • Resolution set to fixed
  • Status changed from new to closed

In 23217:

TinyMCE: update to latest source including the WebKit backspace fix, fixes #23010, fixes #22766 for 3.5

Note: See TracTickets for help on using tickets.