WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 7 weeks ago

#23332 closed defect (bug) (fixed)

iPad Can't Move Cursor in Visual Editor

Reported by: miqrogroove Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: TinyMCE Keywords:
Focuses: Cc:

Description

I've been ramping up iPad usage with WordPress both for mobility as well as testing.

The more I use it, the more frustrated I become with the visual editor. Due to what appears to be multiple bugs with both iOS and WordPress, I am often unable to move the cursor and must switch to the Text tab to do my editing.

When tapping into the Visual editor in a long post, the screen auto scrolls so that the cursor is sitting directly above the keyboard, and the admin bar moves to the middle of the page, covering most of the remaining editing area. This blocks the view of any preceing or following text, and makes it very awkward to write sentences longer than the editor is wide.

To move the cursor to a different part of the post, I have to un-focus the editor and the tap into the editor on a different line. The only place I can reliably land the cursor is at the end of a line, so to change anything in the middle of a paragraph, I have to use the text editor.

Change History (9)

comment:1 @miqrogroove2 years ago

Also, it is impossible to scroll up or down while typing because the iPad keyboard stops responding.

comment:3 @MikeHansenMe2 years ago

  • Cc mdhansen@… added

Related: #22519

comment:4 @Ipstenu16 months ago

  • Keywords close added

This seems to have been fixed by Apple. On iOS7 it's working

  • Scrolling in a text box works
  • Keeping text box active to click/move cursor works

That said, there are some iOS bugs that randomly causes your browser to change focus without warning, which is a pill, but it's iOS and not WP (Chrome devs were kvetching about that too).

Suggest close.

comment:5 @miqrogroove16 months ago

I'm trying this now.

Not Fixed:

  • After moving the cursor, cannot move cursor back to end of post.

Workaround:

  • Moving focus to the Tags field enables me to re-focus the textbox with the cursor at end of post.

Fixed:

  • Possible to scroll while typing.

At this point I would describe the visual editor as barely usable. Being unable to continue the end of a post is a big problem for me.

Last edited 16 months ago by miqrogroove (previous) (diff)

comment:6 @miqrogroove16 months ago

  • Keywords close removed

Please note this bug does not exist in the TinyMCE demo page. I do not agree with closing this ticket.

comment:7 @azaozz13 months ago

  • Milestone changed from Awaiting Review to Future Release

Yeah, there seem to be quite a few problems with contenteditable in iOS Safari, and many are not being fixed or the fixes take years... Most seem caused by the onscreen keyboard. If it's closed all works somewhat better.

Not really sure if we can do anything to improve that. A good workaround for many of these problems is to force-close the keyboard, then open it again by tapping at the desired location.

comment:8 @iseulde7 weeks ago

  • Component changed from Editor to TinyMCE

comment:9 @azaozz7 weeks ago

  • Milestone Future Release deleted
  • Resolution set to fixed
  • Status changed from new to closed

I believe all of these have been fixed in both TinyMCE 4.1 and iOS 8.1. Older versions of iOS may still experience some of the problems, unfortunately there is next to nothing we can do fix them there.

Closing as fixed (upstream). Feel free to reopen if some of these problems still exist and we can do anything to fix them.

Note: See TracTickets for help on using tickets.