Make WordPress Core

Opened 11 years ago

Closed 12 months ago

Last modified 11 months ago

#23348 closed task (blessed) (fixed)

Add a "Contribute" tab to the about page

Reported by: suzettefranck's profile suzettefranck Owned by: oglekler's profile oglekler
Milestone: 6.3 Priority: normal
Severity: normal Version: 3.5
Component: Help/About Keywords: has-unit-tests has-copy-review has-patch dev-reviewed
Focuses: ui, administration Cc:

Description

The path to find out how to contribute is several levels deep in WordPress itself. Right now, you have to click on the W icon, then About WordPress, then the Credits tab, and then scroll down to the bottom of that page to see a micro link in the footer: Want to see your name in lights on this page? Get involved in WordPress.

Also, only Core Contributors are on this list so it gives a false promise of being listed on this page if you contribute which is not the case.

We discussed adding a link in #wordpress-sfd and everyone thought this would be a good idea so that more people could find out how to get started in contribution.

I am new to creating tickets so please let me know if there is any other information you need!

Attachments (16)

23348.diff (6.3 KB) - added by Shelob9 10 years ago.
23348-screenshot.png (51.4 KB) - added by Shelob9 10 years ago.
23348-screenshot-2.png (132.3 KB) - added by Shelob9 9 years ago.
23348.2.diff (1.0 KB) - added by desrosj 6 years ago.
Archive-PNGs-Optimized and @2xs.zip (5.8 MB) - added by cathibosco1 6 years ago.
The Four Freedom Illustrations
23348.3.diff (9.6 KB) - added by oglekler 15 months ago.
contribute-tab-draft-preview.png (56.5 KB) - added by oglekler 15 months ago.
Contribute-tab.png (140.2 KB) - added by oglekler 13 months ago.
Contribute-tab-menu-adoptation.png (70.2 KB) - added by oglekler 13 months ago.
23348.5.diff (10.0 KB) - added by marybaum 13 months ago.
Copy changes to correct English grammar and smooth out tone
23348.4.diff (10.9 KB) - added by ryelle 13 months ago.
contributor.png (868.5 KB) - added by ryelle 13 months ago.
Contribute-tab-new-content.png (178.8 KB) - added by oglekler 13 months ago.
Contribute-tab-new-content-updated.png (186.9 KB) - added by oglekler 12 months ago.
Contribute-tab-final-final-version.png (181.3 KB) - added by oglekler 12 months ago.
23348.6.diff (1.9 KB) - added by SergeyBiryukov 12 months ago.

Change History (183)

#1 @mt_suzette
11 years ago

Here is the discussion from #wordpress-sfd:

mt_Suzette: Wouldn't be helpful to point /encourage people to contribute somewhere in WordPress itself? Like in the dashboard? or welcome screen?

[1:55pm] Siobhan: I think there is something on the welcome screen

[1:56pm] Siobhan: Maybe a Contribute link on the menu with the WordPress logo in the admin bar. That's probably one for the community group tho

[1:57pm] DrewAPicture: That would be awesome

[1:57pm] mt_Suzette: I looked on the Welcome Screen, I didn't see anything about how to get started contributing, just a link of where to start

[1:57pm] mt_Suzette: (using WordPress)

[1:57pm] Siobhan: hrm

[1:57pm] Siobhan: Maybe raise a ticket on Trac? Make the suggestion?

[1:58pm] DrewAPicture: It might be on credits page?

[1:58pm] DrewAPicture: At the bottom of the credits tab: Want to see your name in lights on this page? Get involved in WordPress.

[1:58pm] DrewAPicture: Links to http://codex.wordpress.org/Contributing_to_WordPress

[1:59pm] Siobhan: The problem with that is, the credits tab is just core folks

[1:59pm] Siobhan: And we don't want to indicate that people can get there by contributing to any area

[2:01pm] mt_Suzette: I couldn't find the credits page, but I have seen it before

[2:02pm] Siobhan: I can't find it either

[2:03pm] JerrySarcastic: from the dashboard, click on the WordPress icon>About WordPress and then click on the tab Credits

[2:04pm] JerrySarcastic: Easy, am I right?

[2:04pm] Siobhan: are you ever wrong?

[2:04pm] JerrySarcastic: Ask my lady...

[2:04pm] mt_Suzette: Yes, I see it now, but that seems rather hidden

[2:05pm] JerrySarcastic: That's an understatement.  

[2:05pm] DrewAPicture: I like the idea of a make.wordpress.org link in the W dropdown though.

[2:05pm] DrewAPicture: Especially if we get a makeover on that page

[2:05pm] Siobhan: yeah, that would be nice

[2:05pm] JerrySarcastic: Esp. if it says something simple, like "Contribute" in teh dropdown

[2:06pm] Siobhan: Alright - that's something we can all approve of

[2:06pm] Siobhan: Someone open a ticket on trace?

[2:06pm] Siobhan: ^trac
Last edited 11 years ago by DrewAPicture (previous) (diff)

#2 @DrewAPicture
11 years ago

  • Cc DrewAPicture added

#3 @JerrySarcastic
11 years ago

  • Cc fittingsites@… added

#4 @markoheijnen
11 years ago

My opinion is that WordPress core is not the place for a contribute link. However it should be more prominent on WordPress.org and the make websites.

#5 follow-up: @nacin
11 years ago

Until there is an top-dollar entrance/landing page for contributing to all things WordPress (which I hope comes in 2013), thinking we should pass on this.

#6 @mt_Suzette
11 years ago

  • Cc mt_Suzette added
  • Resolution set to maybelater
  • Status changed from new to closed

#7 @SergeyBiryukov
11 years ago

  • Component changed from Inline Docs to Toolbar
  • Keywords needs-ui removed
  • Milestone Awaiting Review deleted

#8 in reply to: ↑ 5 ; follow-up: @jenmylo
11 years ago

Replying to nacin:

Until there is an top-dollar entrance/landing page for contributing to all things WordPress (which I hope comes in 2013)

Working on it currently with @ievolver and @stephanis, hoping to launch v1 sometime in February.

That said, a link from the W is separate from the "only Core Contributors are on this list so it gives a false promise of being listed on this page if you contribute" issue raised, so let's not conflate the two. If someone wants to suggest altering the credits page approach, a new ticket should be created for that.

#9 in reply to: ↑ 8 @SergeyBiryukov
11 years ago

Replying to jenmylo:

If someone wants to suggest altering the credits page approach, a new ticket should be created for that.

Related: #22305

#10 @sabreuse
11 years ago

  • Cc sabreuse added

#11 @nacin
10 years ago

#30923 was marked as a duplicate.

#12 @SergeyBiryukov
10 years ago

  • Component changed from Toolbar to Help/About
  • Milestone set to Awaiting Review
  • Resolution maybelater deleted
  • Status changed from closed to reopened
  • Summary changed from Add Contribute Link in W icon dropdown in admin toolbar to Add a "Contribute" tab to the about page

#13 @Shelob9
10 years ago

  • Focuses administration added

In the past this idea was not considered ready. @nacin said until there is a "top-dollar entrance/landing page for contributing to all things WordPress" this was a no-go and people agreed. Now that we have https://make.wordpress.org/ and it is pretty awesome, I think it's time to re-consider.

I have a patch that adds a "Contribute" tab to the "About" page. It focuses less on contributing to core, and more on other ways to contribute to the project--docs, theme review, accessibility--that are less apparent to those who are new to the idea.

My parch should be considered a draft proposal and while most of its language is lifted from the make site, I'm sure the text will need some revision. That said, I think it's passed time to add this in some form or another and wanted to start the conversation.

@Shelob9
10 years ago

#14 @SergeyBiryukov
10 years ago

  • Milestone changed from Awaiting Review to 4.2

#15 @Shelob9
9 years ago

  • Keywords has-patch added

This ticket was mentioned in Slack in #core by drew. View the logs.


9 years ago

#17 @helen
9 years ago

  • Milestone changed from 4.2 to Future Release

Thanks for patching, @Shelob9. This ticket really needs a design and content direction first and foremost before it can really be considered. Would be great to have some people take point on that.

I am going to move this out of 4.2 for the moment, it's easily brought back as things progress. Putting in Future because I do think it's a valuable addition somewhere.

#18 @Shelob9
9 years ago

@helen Thanks for the feedback. I agree the design could be better, and will try to find some help for that, as I am not a designer. I am also attaching a full screenshot to facilitate discussion.

As far as needing a content direction, I was very intentional in the content. It is designed to show people ways to contribute beyond contributing to core. I don't see any specific feedback in the chat logs on the content itself, but am happy to take feedback and will solicit some feedback in the #outreach Slack channel. The criticism that I would offer myself, looking over it now is that it doesn't link to http://central.wordcamp.org/

I think it is important to keep in mind that the people that we are hopping to reach with this new tab are not those who are already engaged. While, all of these links are available on make.wordpress.org, the goal of this tab is to get people who do not know that is a thing to make their first trip there or to consider a WordCamp or a WordPress Meetup for the first time.

This ticket was mentioned in Slack in #outreach by shelob9. View the logs.


9 years ago

#20 @chriscct7
9 years ago

  • Focuses ui added
  • Version changed from 3.5.1 to 3.5

This ticket was mentioned in Slack in #core by patilswapnilv. View the logs.


8 years ago

This ticket was mentioned in Slack in #outreach by patilswapnilv. View the logs.


8 years ago

This ticket was mentioned in Slack in #core-i18n by ocean90. View the logs.


8 years ago

#24 @ocean90
8 years ago

#33007 was marked as a duplicate.

This ticket was mentioned in Slack in #core-i18n by swissspidy. View the logs.


8 years ago

#26 @lukecavanagh
7 years ago

@Shelob9

Seems like a solid change for about, that should hopefully landing in a future release.

This ticket was mentioned in Slack in #polyglots by sergey. View the logs.


7 years ago

This ticket was mentioned in Slack in #design by karmatosed. View the logs.


6 years ago

#29 follow-up: @boemedia
6 years ago

We discussed this ticket in today's design ticket triage. We agreed this could use more focus and we think the call for designing these tabs could use a design champion to make it more visually appealing :).

However, we don't want to see adding this tab being delayed by design. Therefore, we suggest publishing the tab with the next release, like is done with the privacy tab.

As well, we'd love to see someone from #marketing involved in this for more inviting text.

#30 @SergeyBiryukov
6 years ago

  • Milestone changed from Future Release to 4.9.6

#31 in reply to: ↑ 29 @bridgetwillard
6 years ago

Hey thanks for looping in Marketing, Monique.

We are always happy to provide and/or edit copy for any project.

Specifically the "mostly volunteers" phrase is inaccurate as the official line is that "no one is paid to make WordPress," though we know that many volunteers are sponsored.

A few things pop out to me.

1. Without creating a Tab, possible solution is to move text.

We could move the line at the very bottom that says

"Want to see your name in lights on this page? Get involved in WordPress."

under

"WordPress is created by a worldwide team of passionate individuals."

2. The tab is a good solution, let's make the copy compelling.

Include more teams and/or a video of a Contributor and their story. @andreamiddleton has told a lot of success stories over the last year or so in her WordCamp talks including @melchoyce. A "Like Me" campaign to recruit volunteers works.

3. Why here?

I've been using self-hosted WordPress since 2015 and even though I wrote the copy for 4.8's about page, I didn't even realize there were other tabs here. I update and move on. Meaning, I don't pay attention to this, and I'm a) your target demo of people who contribute without code; and b) a Marketing Team Rep.

We should be careful about user bias. If people don't look at this page, it's not going to be a helpful recruiting tool to have a tab.

That said, I'm glad @mt_Suzette opened this ticket and it takes a lot of guts to put your ideas out in the open.

4. We should make it easier to contribute. But.

The Marketing Team just created a [1 page PDF for Contributor Days]https://wordpress.slack.com/files/U26LTC54Z/FA53HGK0U/contributorday-onboardingpdf-041118.pdf that may also be good for Contributor Drives at WordPress Meetups.

Ever since 4.8 and the WordPress News and Events widget, Meetup attendance has grown (anecdotally, though I suppose Community has some stats).

5. What if we put this idea in a dashboard widget (higher visibility)?

Iteration?? Or crazy idea?

Those are my thoughts.

Love y'all.

Bridget


Replying to boemedia:

We discussed this ticket in today's design ticket triage. We agreed this could use more focus and we think the call for designing these tabs could use a design champion to make it more visually appealing :).

However, we don't want to see adding this tab being delayed by design. Therefore, we suggest publishing the tab with the next release, like is done with the privacy tab.

As well, we'd love to see someone from #marketing involved in this for more inviting text.

#32 @boemedia
6 years ago

Totally agree with your comments on visibility, Bridget. I actually never clicked the ‘W’ before I started contributing. And I only quickly scan the first tab on new releases. Findability here is a key thing, however, information overload could be a problem if we need to create dashboard widgets for this type of information. Therefore I think moving this text up on the first tab would be a solution I prefer, I combintation with a more visual appealing design to make the part about contributing stand out more.

#33 @jeffmora
6 years ago

From contributor day in WordCamp Madrid 18, I would like to say that improving the visibility of the community is a really good idea, as well as showing the posibility of being part of this, helping with anything that one can provide. How about show the different teams that people could be part of? It would be something simple, with icons as in get involved but without the descriptions, or with shorter descriptions.

@desrosj
6 years ago

#34 @desrosj
6 years ago

23348.2.diff moves the text from the bottom of the page to the location @bridgetwillard suggested. I think this is the only thing we could land in 4.9.6.

A new tab should probably not be added in a minor, anyway.

#35 @SergeyBiryukov
6 years ago

  • Keywords commit added

23348.2.diff looks good to me.

#36 @SergeyBiryukov
6 years ago

In 43032:

Help/About: Move "Get involved" link on Credits screen to the top of the page for better visibility.

Props bridgetwillard, desrosj.
See #23348.

#37 @SergeyBiryukov
6 years ago

In 43033:

Help/About: Move "Get involved" link on Credits screen to the top of the page for better visibility.

Props bridgetwillard, desrosj.
Merges [43032] to the 4.9 branch.
See #23348.

#38 @SergeyBiryukov
6 years ago

  • Milestone changed from 4.9.6 to 4.9.7

#39 @SergeyBiryukov
6 years ago

  • Keywords commit removed

#40 @cathibosco1
6 years ago

This came up in a design team meeting a few weeks ago... I'd like to make a couple of recommendations.

I recommend an additional tab would be helpful
"Get Involved" - A short intro and below links to various teams much much like this page https://make.wordpress.org/
It has the links needed for getting involved...
(but maybe this was resolved with simply moving the link up)

When that page gets updated - so should this tab. We would be happy to provide some illustrations or styles etc...

Also I think the content under the Freedoms Tab could use a big refresh. Recently the About Page https://wordpress.org/about/
got a big refresh and with that we got some new illustrations from the design team for each of the freedoms.
Let's get that tab up to date based on the /about page.

This would be very "actionable" for us to add/update now and also for peeps to take action through.

https://d.pr/i/NbcZfd

https://d.pr/i/m62Otd

I have .png files of all illustrations - let me know who to get them to so we can proceed. :)

Last edited 6 years ago by cathibosco1 (previous) (diff)

This ticket was mentioned in Slack in #design by cathibosco. View the logs.


6 years ago

#42 @cathibosco1
6 years ago

I have all of the Freedom Graphics from the design team in two .png layout formats - rectangle and square.
They are all also in 2x variations as well...

I can't seem to add the compressed file here. argh I FIGURED IT OUT!

Please let me know who I can get them to - I can always upload them to the Design Channel in Slack? - Thank you

Last edited 6 years ago by cathibosco1 (previous) (diff)

@cathibosco1
6 years ago

The Four Freedom Illustrations

#43 @desrosj
6 years ago

  • Milestone changed from 4.9.7 to 4.9.8

Moving all tickets in 4.9.7 to 4.9.8.

This ticket was mentioned in Slack in #core by joshuawold. View the logs.


6 years ago

#45 @pento
6 years ago

  • Keywords needs-patch added; has-patch removed
  • Milestone changed from 4.9.8 to Future Release

This needs an owner to be milestoned.

This ticket was mentioned in Slack in #design by karmatosed. View the logs.


5 years ago

#47 @karmatosed
5 years ago

  • Keywords needs-design added; ui-feedback removed

For now, adding in 'needs design' to ensure this gets the right keyword.

This ticket was mentioned in Slack in #core by abhanonstopnews. View the logs.


3 years ago

This ticket was mentioned in Slack in #core by oglekler. View the logs.


16 months ago

#50 @marybaum
16 months ago

  • Owner set to oglekler
  • Status changed from reopened to assigned

#51 @marybaum
16 months ago

  • Milestone changed from Future Release to 6.3

This ticket was mentioned in Slack in #core by oglekler. View the logs.


16 months ago

#53 @oglekler
16 months ago

From previous Slack discussion (17 months ago):

audrasjb 10:41 PM
The main question is the content we want to show, because there is already a link to make.wordpress.org on the credits screen

costdev 10:41 PM
Also, would this be a 'live' tab for updates across versions or would this need to be generalised to a point of 'futureproofed'?

marybaum 10:42 PM
I think we can focus all that discussion on https://core.trac.wordpress.org/ticket/23348

audrasjb 10:42 PM
maybe a reproduction of the Make teams listed on make.wordpress.org would work, but we need content, design, etc :slightly_smiling_face:

From the discussion 15, March, 2023:

costdev 11:29 PM
I think a menu item directly under (W) might be useful too/instead. Gets someone there quicker. The current links are: About WordPress, WordPress.org, Documentation, Support, Feedback. I think a Contribute link might be useful there

_

This new Contribute page/tab can be a bit for improving onboarding process, mentioned by Hari Shanker R:
https://make.wordpress.org/project/2023/02/06/proposal-creating-a-wordpress-contributor-mentorship-program/

On this page we can tell about different ways to contribute to WordPress in easy to understand, appealing language. It is possible that many WordPress users don't even imagine all the ways that they can contribute to WordPress and how many skills and talents current contributors use and develop contributing to WordPress.

Plus, a link to the Orientation tool can be useful as well.

It is described here: https://make.wordpress.org/community/2019/06/17/contributor-orientation-tool/ bit link for itself if not working anymore.

This tool can be placed as a link/banner on the Make home page as a block "What team is best suited for me?"


  • We can make information and structure of this page/tab timeless as possible, but update styling according to related About page appearance.
  • It will be great to see the Contribute page as the About page tab and a link under (W) at the same time. In addition, see the proposal to improve the About page visibility: #57877

I created a ticket in the Marketing team GitHub to work on the structure and content of the tab: https://github.com/WordPress/Marketing-Team/issues/217

All input is welcome 🙌

This ticket was mentioned in Slack in #core by sergey. View the logs.


15 months ago

#55 @davidmusnik
15 months ago

Hello people,

I have been investigating this issue during the contributing day organized by WPFR in Paris on April 20th, 2023. For the record, this is the first time the person writing this comment is participating to such an event.

Adding a contribute option should involve several modifications :

1- wp-admin/about.php

This first modification creates a new element in an array as well as a new file which might be named « contribute.php », in line with the other options such as «about», «credits», «freedoms» and «privacy». More precisely:

<?php
<nav class="about__header-navigation nav-tab-wrapper wp-clearfix" aria-label="<?php esc_attr_e( 'Secondary menu' ); ?>">
        <a href="about.php" class="nav-tab nav-tab-active" aria-current="page"><?php _e( 'What&#8217;s New' ); ?></a>
        <a href="credits.php" class="nav-tab"><?php _e( 'Credits' ); ?></a>
        <a href="freedoms.php" class="nav-tab"><?php _e( 'Freedoms' ); ?></a>
        <a href="privacy.php" class="nav-tab"><?php _e( 'Privacy' ); ?></a>
        <a href="contribute.php" class="nav-tab"><?php _e( 'Contribute' ); ?></a>
</nav>

In addition to this change, all other PHP files which display the secondary menu, say « about.php », « credits.php », « freedoms.php » and « privacy.php » should also be modified to include this new contribute entry in that very secondary menu.

1.1- wp-admin/contribute.php

This new file, heavyly country dependant, requires further design in line with the other {«about», «credits», «freedoms» and «privacy»} internal pages already in place.

2- wp-includes/admin-bar.php

This modification involves the creation of a new node in an existing one as listed below. Obviously, the href element of the code should be localized according to the country under considération.

<?php
$wp_admin_bar->add_node(
        array(
        'parent' => 'wp-logo-external',
        'id'     => 'Contribute',
        'title'  => __( 'Contribute' ),
        'href'   => __( 'https://wordpress.org/support/article/contributing-to-wordpress/' ),
                )
        );

This ticket was mentioned in PR #4431 on WordPress/wordpress-develop by @oglekler.


15 months ago
#56

  • Keywords has-patch added; needs-patch removed

Draft for the new Contribute Tab for the About page. The purpose of this PR is to move the ticket forward — allow other contributors to see how it can look and baseline to work on further.

Trac ticket: #23348

@oglekler
15 months ago

#57 @oglekler
15 months ago

Hi @davidmusnik, thank you for your input.

The most difficult question is what to write on this tab, to make information appealing and lasting without need to reinvent it with each release.

I invite you and everyone to collaborate on the marketing ticket https://github.com/WordPress/Marketing-Team/issues/217 and make input in the content draft.

This ticket was mentioned in Slack in #core by oglekler. View the logs.


15 months ago

#59 @audrasjb
15 months ago

The proposal looks nice to me, except for the “Pick your favourite language or library” section: several listed languages are not used at all in WordPress :)

Maybe the best way to iterate would be to create a shared document?

#61 @mehdi01
14 months ago

Thank you @mt_suzette for your proposal.

The proposal is really great to me. beside that another section can be added which is "Event" Section. So that people can see specifically how many event have you attended and what was you role to it. I'm planning to make a design for the event section.

Last edited 14 months ago by mehdi01 (previous) (diff)

This ticket was mentioned in Slack in #meta by sereedmedia. View the logs.


14 months ago

#63 @oglekler
13 months ago

Hi @audrasjb and @mukesh27, I've updated the patch and added screenshots (just above) of how it looks right now.

#64 @davidbaumwald
13 months ago

I appreciate all of the work put in here so far. I do have one slight concern. I feel like this heading "Hot to find the team you will enjoy" my need some tweaking. Specifically, the word "Hot" in this context is a bit odd. Not trying to be a boomer, I just this there's better alternative to the word "Hot". I'm also thinking about how this might have various meaning when translated. Perhaps "Eager", "Ready", or some other word there would not have these same issues?

#65 @oglekler
13 months ago

@davidbaumwald thank you for spotting this, I definitely felt hot. Your suggestions are more interesting than what I intended to put, so, let's try to enjoy things eagerly, and I believe that after this Tab will go live we will have a ton of suggestions for improvements. I updated the patch.

#66 @johnbillion
13 months ago

Is that not just a typo of "How"?

#67 @bridgetwillard
13 months ago

Instead of "Take part in WordPress development" I'd like to see text that is more inclusive of other teams like marketing and design.

H1: Contribute to WordPress
H2: The WordPress Project Needs You

H1: Contribute to the WordPress Project
H2: Be Part of WordPress History

I agree with "hot" as well.

"Get Started" or "Ready. Set. Go." might be better calls to action (CTAs) for signing up.

#68 @oglekler
13 months ago

  • Keywords needs-testing added; needs-design removed

#69 @davidbaumwald
13 months ago

  • Keywords needs-copy-review added

In reading the copy in the current patch, I really feel like this would benefit from a thorough review to ensure the messaging matches all other aspects of the project.

#70 @oglekler
13 months ago

@davidbaumwald I am begging 3 months for this copy-review 😶

@marybaum
13 months ago

Copy changes to correct English grammar and smooth out tone

#71 @marybaum
13 months ago

  • Keywords has-copy-review added; needs-copy-review removed

I just added a new patch that smoothes out the flow of the text, corrects US English grammar and punctuation, and makes a few concepts easier for a new contributor to understand and buy into.

@ryelle
13 months ago

@ryelle
13 months ago

#72 @ryelle
13 months ago

I had some trouble getting the latest diff to apply, so I patched it together and uploaded a new version 23348.4.diff (which has the changes from the PR and 23348.5.diff). I also fixed a php syntax error, made the make.wordpress.org a link — see the attached screenshot contributor.png — and added in the link on the Privacy page :)

Are there illustrations planned for all the image placeholders here? I just want to make sure we're considering future iterations— the image style doesn't change with every release, but it can, so any images that are added could add work for future designers.

I think we might want to rethink the nav, maybe just shrink it down a little. These tabs break out when the translated words are longer (to be fair, this was already true at ~550px). Not a blocker here, but could be worth addressing soon.

Rather than localizing the "Non-technical" links, we could use the current user's locale to build URLs, like support for someone using WP in spanish could link to es.wordpress.org/support/, same for the photo directory. I'm not sure where the translate links would go exactly, maybe something like https://translate.wordpress.org/locale/es/default/wp/dev/? Maybe the "test" item could go to a Make Test Handbook page?

Could we turn some of these bullet lists into paragraphs? Especially the nested list at the end, I think we could use that space as a call to action to link to the different projects.

The link at the end, https://make.wordpress.org/contribute/, doesn't exist— is there a plan to publish something there before this is released?

#73 @audrasjb
13 months ago

  • Type changed from enhancement to task (blessed)

Converting to a task as this can ship after beta 1 is released.

#74 @jpantani
13 months ago

@oglekler and crew - thanks for getting this under my eyes and highlighting some of the opportunities that exist for leveling up the content here.

What I was able to gather from this thread is that we'd like to get a section that actively speaks to folks about getting them excited to 'Get involved and contribute. And to do so in a way that's consistent with [brand voice and writing style]https://make.wordpress.org/marketing/handbook/resources/style-guide-and-brand-book/

I recommend an overhaul of the copy to help accomplish that. It's not a huge overhaul, but it is one that adds charm and familiarity. I also noted that turning some of the text into paragraphs was a request, and this proposal has a good bit of sentence structure built into it.

[Here's my draft]https://docs.google.com/document/d/1F2-75YqtZ2-15DWiNEc0Q6XYg0d-KS7tBFZlpkATbyk/edit, which I can then work into actual copy changes. (it's open to all for commenting)

I'm recommending these changes to bring a strong sense of energy and think of it as recruitment e.g. "Join our club. There's room for you and your talents!" I aim to reach people's sense of purpose and belonging. So I really leaned into that while making sure things remained on brand.

My proposed next steps are to have a brief comment period for, let's say, the next week (July 3/4) or so and then commit these things for Beta 3 or July 11 if that works for everyone. Does that work for folks so we can move forward?

#75 @oglekler
13 months ago

Contributor day Orientation Tool is planned to be put into /contribute/ Meta page,
how it looks like:
https://wpasia.org/contributor-day-orientation-tool/
Source:
https://github.com/wceu/contributor-orientation-tool

More information: https://github.com/WordPress/Marketing-Team/issues/217

Last edited 13 months ago by oglekler (previous) (diff)

#76 follow-up: @SeReedMedia
13 months ago

I've (rather heavily, sorry) edited the draft content @jpantani prepared in the Google Doc above. @jpantani can you implement the changes folks have requested and reiterate with a fresh doc?

I've also created a meta ticket to make the /contribute page happen: https://meta.trac.wordpress.org/ticket/7105#ticket

This needs a lift from meta to turn into a real page and a review from @alexstine to ensure accessibility for the contributor tool.

#77 in reply to: ↑ 76 ; follow-up: @jpantani
13 months ago

Lots of review and improvements have been made to the copy doc.

https://docs.google.com/document/d/1F2-75YqtZ2-15DWiNEc0Q6XYg0d-KS7tBFZlpkATbyk/edit

There is one space-permitting callout near the end but it also offers an ALT in the case that tech language and library section won't fit.

@SeReedMedia I'd say clean up is complete.

#78 in reply to: ↑ 77 @SeReedMedia
13 months ago

This text is looking SO GOOD!!! What a great example of working together and quickly! So stoked on everyone's work on this! Go team!

Replying to jpantani:

Lots of review and improvements have been made to the copy doc.

https://docs.google.com/document/d/1F2-75YqtZ2-15DWiNEc0Q6XYg0d-KS7tBFZlpkATbyk/edit

There is one space-permitting callout near the end but it also offers an ALT in the case that tech language and library section won't fit.

@SeReedMedia I'd say clean up is complete.

#79 @oglekler
13 months ago

I updated the content according to the document above and changed the layout a bit to fit it. Please take a look, RC1 with a string freeze is coming, and we have a lot of content.

This ticket was mentioned in Slack in #core-test by oglekler. View the logs.


13 months ago

#81 @oglekler
13 months ago

@fierevere can you place take a look at the patch from a Polyglot point of view 🙏. I had no better idea about bold highlights in strings.

https://github.com/WordPress/wordpress-develop/pull/4431/files

#82 @fierevere
13 months ago

Looks good for me, please check line 76 for possibly broken placeholder s%

#83 @tobifjellner
13 months ago

src/wp-admin/contribute.php 49-50
Please avoid using &#37; for percent sign. Much better to simply say %% and add a note in Translators comment: %% is a percent sign and needs to be escaped like this here.


Reading further.

#84 @tobifjellner
13 months ago

src/wp-admin/contribute.php :76
Needs to use _n()

That's this line:

__( 'Finding the area that aligns with your skills and interests is the first step toward meaningful contribution. With more than %s Make WordPress teams working on different parts of the open-source WordPress project, there&#8217;s a place for everyone, no matter what your skill set is.' ),

Alternatively, just hardcode that "more than 20" directly in the string. It won't change too often.

Last edited 13 months ago by tobifjellner (previous) (diff)

#85 @audrasjb
12 months ago

Thanks for the review.
@tobifjellner I added two commits to take your proposals into account

#86 @richtabor
12 months ago

  1. How about we add the "Find your team" CTA under the "Find your team" paragraph? The actions should be correlated to the topics covered.
  1. And then adapt the last "Find your team" CTA (can be the same link) to "Get Involved"? This follows the same CTA on WordPress.org.
Last edited 12 months ago by richtabor (previous) (diff)

#87 @richtabor
12 months ago

Couple other notes:


How about we add the "Find your team" CTA under the "Find your team" paragraph? The actions should be correlated to the topics covered.

Scratch that — I don't think we need the "Find your team" section; those bits are said elsewhere on the page as well.


Why don't we use the comms already in place on WordPress.org. Here's what's on the homepage that flows very well:

Behind the technology is a diverse collective of people, collaborating from around the world. We’re united by the spirit of open source, and the freedom to build, transform, and share without barriers.

From writing code and testing, to community outreach and translation, there are so many ways to contribute and everyone is welcome. Let’s shape the future of the web together.


"Help Make WordPress Better" should be sentence case like the other headings — i.e. "Help make WordPress better". I also don't love the "MAGA" ring to it (unintentional I know).

But really, the page doesn't really need this section either.


Suggestion for the code contribution section (pulled from make.wordpress.org):

Code Contribution
Whether you’re a seasoned developer or are just learning to code, we’d love to have you on board. You can write code, fix bugs, debate decisions, and help with development.


No-code contribution section:

"Lend your creative imagination to the WordPress UI designy" doesn't ring well.
"Take photos for or helo curate the WordPress Photos Directory" could be "Photograph for..."


A couple typos & grammar:

  • "designy" should be "design".
  • "With more than sake WordPress" should be (in the find your team section that I don't think we need).
  • "Apply your skills or learn some new ones" to "Apply your skills and learn something new"
  • "Take photos for or helo curate..." to "Take photos for or help curate"

---

Let's add periods to the end of the list items, as they're sentences.

Last edited 12 months ago by richtabor (previous) (diff)

#88 @SergeyBiryukov
12 months ago

In 56220:

Help/About: Add a “Get Involved” tab to the About page.

This aims to make all the various ways of contributing to open-source WordPress project more discoverable, as well as make it easier to find an area that aligns with new contributor’s skills and interests.

Props oglekler, jpantani, SeReedMedia, ryelle, marybaum, karmatosed, eidolonnight, mt_suzette, Shelob9, desrosj, cathibosco1, jenmylo, nacin, helen, joostdevalk, hugobaeta, TacoVerdo, swissspidy, markoheijnen, lukecavanagh, boemedia, bridgetwillard, jeffmora, davidmusnik, mehdi01, johnbillion, fierevere, tobifjellner, richtabor, meher, courane01, webcommsat, audrasjb, mukesh27, davidbaumwald, costdev, joedolson, robinwpdeveloper, estelaris, mohiuddinomran, SergeyBiryukov.
See #23348.

@SergeyBiryukov commented on PR #4431:


12 months ago
#89

Thanks everyone! Merged in r56220.

#90 @richtabor
12 months ago

I noted a number of inconsistencies to follow up on in this comment above, including grammatical. (https://core.trac.wordpress.org/ticket/23348#comment:87).

#91 @SeReedMedia
12 months ago

I've updated the content doc with the remaining edits and suggestions, including the sentence case for the two H3 headlines. And @richtabor we are moving that "Find Your Team" section to the bottom as you suggested.

@oglekler will (or maybe has already) incorporate those updates into the trunk.

However first we need to update the headline for the call-to-action section because the button is "Find your team" and I think that is the perfect button CTA. So how does everyone feel about this for the CTA header:

Shape the future of the web with WordPress

The whole section in the bottom CTA section would read:

H2: Shape the future of the web with WordPress

Body (not changed): Finding the area that aligns with your skills and interests is the first step toward meaningful contribution. With more than 20 Make WordPress teams working on different parts of the open-source WordPress project, there’s a place for everyone, no matter what your skill set is. 

Button (not changed): Find your team [make.wordpress.org/contribute]


This ticket was mentioned in PR #4840 on WordPress/wordpress-develop by @costdev.


12 months ago
#92

  • Keywords has-unit-tests added

#93 @costdev
12 months ago

@SergeyBiryukov PR 4840 contains tests to ensure the 'contribute' node is added to the admin bar when appropriate. 🙂

This ticket was mentioned in PR #4841 on WordPress/wordpress-develop by @oglekler.


12 months ago
#94

Content changes incorporating ones proposed by @richtabor;
@sereedmedia and @eidolonnight made the decision.

Trac ticket: #23348

#95 @ibrahimmonir
12 months ago

Test Report

Environment

  • OS: Windows 11
  • Browser: Firefox Version 114.0.2 (64-bit)
  • Server: Nginx/1.25.1
  • PHP: 7.4.33 (Supports 64bit values)
  • WordPress: 6.3-alpha-55505-src
  • Theme: twentytwentythree v1.1
  • Active Plugins: N/A

Steps to Test

  1. Dashboard
  2. Apply Patch
  3. Restart environment
  4. Go http://localhost:8889/wp-admin/contribute.php

Expected Results

Supplemental Artifacts

Image - https://i.ibb.co/6gB5s4L/Screenshot-2023-06-26-at-17-53-21-Contribute-Word-Press-Develop-Word-Press.png

This ticket was mentioned in PR #4842 on WordPress/wordpress-develop by @costdev.


12 months ago
#96

Specifically between 783px and 926px, the menu for the About / Credits / Freedoms / Privacy / Get Involved tabs expands beyond the container when the side admin menu is expanded. This wasn't an issue when there were fewer tabs previously, or when the Get Involved tab was called Contribute.

Video demonstrating the issue:

https://github.com/WordPress/wordpress-develop/assets/79332690/d9f737d2-d139-4b74-b059-bb7fbaf7e7c2

This change adjusts horizontal padding on the tabs between 783px and 926px to resolve the issue.

@mukesh27 commented on PR #4842:


12 months ago
#97

Thanks @costdev for the PR. Instead for adding new media query you can add CSS in @media screen and (max-width: 960px) { media query. WDYT?

@costdev commented on PR #4842:


12 months ago
#98

@mukeshpanchal27 Sounds good to me! I've pushed that change now. Can you pull down the latest changes, run a build + hard refresh, and give it a test?

#99 @SergeyBiryukov
12 months ago

In 56227:

Tests: Add tests to ensure the contribute Toolbar node is added when appropriate.

Follow-up to [56220].

Props costdev.
See #23348.

@SergeyBiryukov commented on PR #4840:


12 months ago
#100

Thanks for the PR! Merged in r56227.

#101 @ugyensupport
12 months ago

Add a "Contribute" tab to the about page

Description

The path to find out how to contribute is several levels deep in WordPress itself. Right now, you have to click on the W icon, then About WordPress, then the Credits tab, and then scroll down to the bottom of that page to see a micro link in the footer: Want to see your name in lights on this page? Get involved in WordPress.
Also, only Core Contributors are on this list so it gives a false promise of being listed on this page if you contribute which is not the case.
We discussed adding a link in #wordpress-sfd and everyone thought this would be a good idea so that more people could find out how to get started in contribution.
I am new to creating tickets so please let me know if there is any other information you need!

Environment

  • WordPress: 6.3-beta4
  • PHP: 8.2.0
  • Server: Apache/2.4.54 (Unix) mod_fastcgi/mod_fastcgi-SNAP-0910052141 OpenSSL/1.0.2u mod_wsgi/3.5 Python/2.7.18
  • Database: mysqli (Server: 5.7.39 / Client: mysqlnd 8.2.0)
  • Browser: Chrome 114.0.0.0 (macOS)
  • Theme: Classic 1.6
  • MU-Plugins: None activated
  • Plugins:
    • Gutenberg 16.2.1
    • WordPress Beta Tester 3.5.2

Steps to Reproduce

  1. Dashboard
  2. Apply Patch
  3. Restart environment
  4. 🐞 Bug occurs.

Expected Results

  1. ✅ Contribute Page

Actual Results

  1. https://ibb.co/CQ83wqW

#102 @oglekler
12 months ago

@ugyensupport and @ibrahimmonir it looks like you tested the first version of the patch.

https://patch-diff.githubusercontent.com/raw/WordPress/wordpress-develop/pull/4841.diff - this is the last patch which needs to be committed before RC1, and this patch applied to current trunk looks like this: https://core.trac.wordpress.org/attachment/ticket/23348/Contribute-tab-final-final-version.png

#103 @alexstine
12 months ago

  • Reporter changed from mt_suzette to suzettefranck

Updating for proper credit.

#104 @SergeyBiryukov
12 months ago

In 56233:

Help/About: Update “Get Involved” tab content with the latest edits.

Follow-up to [56220], [56227].

Props oglekler, richtabor, SeReedMedia, eidolonnight, davidbaumwald, ibrahimmonir, ugyensupport, alexstine, suzettefranck.
See #23348.

@SergeyBiryukov commented on PR #4841:


12 months ago
#105

Thanks for the PR! Merged in r56233.

#106 @SergeyBiryukov
12 months ago

In 56234:

Help/About: Adjust horizontal padding on the tabs under 960 pixels width.

This ensures that the About / Credits / Freedoms / Privacy / Get Involved tabs menu does not expand beyond the container when the side admin menu is expanded.

Follow-up to [56220], [56227], [56233].

Props costdev, mukesh27.
See #23348.

@SergeyBiryukov commented on PR #4842:


12 months ago
#107

Thanks for the PR! Merged in r56234.

#108 @eidolonnight
12 months ago

Minor adjustment: The closing CTA has a hyphenated instance of "open-source" which should be changed to "open source" (the latter being aligned with our writing guidelines and the previous instances within this page).

This ticket was mentioned in PR #4851 on WordPress/wordpress-develop by @costdev.


12 months ago
#109

This PR is a placeholder for various fixes to the Contribute tab ahead of 6.3 RC1.

This ticket was mentioned in Slack in #core by mukeshpanchal27. View the logs.


12 months ago

#111 @oglekler
12 months ago

@SergeyBiryukov can you please commit the last PR 😇. It looks like this is the final fix. After this, ticket can be closed 🎉. Thank you 🙏

Great work, everyone 🙌

@audrasjb commented on PR #4851:


12 months ago
#112

Thanks for the PR. Committing right now 👍

#113 @audrasjb
12 months ago

In 56259:

Help/About: String changes in the Contribute screen.

Follow-up to [56220], [56227], [56233], [56234].

Props costdev.
See #23348.

#114 @audrasjb
12 months ago

  • Resolution set to fixed
  • Status changed from assigned to closed

Thanks everyone!

#116 @ryelle
12 months ago

  • Keywords needs-design added; has-patch needs-testing removed
  • Resolution fixed deleted
  • Status changed from closed to reopened

Reopening this ticket because it still needs the illustrations for the three placeholder areas, a main illustration, one for "No-code contribution", and one for "Code-based contribution."

The illustrations should just be decorative, so this can be done post RC, it won't introduce new strings.

#117 @ugyensupport
12 months ago

@oglekler Yes it looks like this after the patch included in WordPress 6.3 RC 1
https://ibb.co/V90xZ6m

This ticket was mentioned in PR #4883 on WordPress/wordpress-develop by @ryelle.


12 months ago
#119

  • Keywords has-patch added

This adds the new images from @richtabor & @marko-srb to the Get Involved tab:

https://i0.wp.com/github.com/WordPress/wordpress-develop/assets/541093/4df24075-898b-4707-9809-5b620b9f71f3

Trac ticket: https://core.trac.wordpress.org/ticket/23348

This ticket was mentioned in Slack in #core by audrasjb. View the logs.


12 months ago

#121 @ryelle
12 months ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In 56290:

Help/About: Add illustrations to the Get Involved tab

Follow-up to [56220], [56227], [56233], [56234], [56259].
Props richtabor, markoserb.
Fixes #23348.

#122 @ryelle
12 months ago

  • Keywords commit dev-feedback added; needs-design removed
  • Resolution fixed deleted
  • Status changed from closed to reopened

Reopening to backport [56290] to the 6.3 branch.

#123 @peterwilsoncc
12 months ago

  • Keywords dev-reviewed added; dev-feedback removed

[56290] approved for backport to the 6.3 branch.

@ryelle commented on PR #4883:


12 months ago
#124

Committed in r56290

#125 @audrasjb
12 months ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In 56293:

Help/About: Add illustrations to the Get Involved tab.

Follow-up to [56220], [56227], [56233], [56234], [56259].

Props richtabor, markoserb.
Reviewed by peterwilsoncc, audrasjb.
Merges [56290] to the 6.3 branch.
Fixes #23348.

#126 @ryelle
12 months ago

  • Keywords has-patch commit dev-reviewed removed
  • Resolution fixed deleted
  • Status changed from closed to reopened

When in the Network admin, the Get Involved tab doesn't work because the file /wp-admin/network/contribute.php does not exist.

Should just need a file like https://core.trac.wordpress.org/browser/trunk/src/wp-admin/network/about.php to avoid the error.

This ticket was mentioned in Slack in #core by ryelle. View the logs.


12 months ago

This ticket was mentioned in PR #4908 on WordPress/wordpress-develop by @audrasjb.


12 months ago
#128

  • Keywords has-patch added

#129 @audrasjb
12 months ago

The above PR fixes the issue.
Note: props should go to @courane01 who spotted the issue during the RC2 release party :)

This ticket was mentioned in PR #4909 on WordPress/wordpress-develop by @courane01.


12 months ago
#130

Sending folks to https://make.wordpress.org/contribute for a short survey on what team they may be interested in joining. This coincides with the Get Involved tab.

Please test against Multisite.

https://core.trac.wordpress.org/ticket/23348

@audrasjb commented on PR #4909:


12 months ago
#132

I suppose there is no localized equivalent of this URL?
In this case, the proposed PR looks good to me.

@audrasjb commented on PR #4909:


12 months ago
#133

_(and I can confirm that this will work on multisite as well)_

#134 @audrasjb
12 months ago

In 56309:

Help/About: Fix the Get Involved tab on Network Admin.

This changeset adds a wp-admin/network/contribute.php file to allow the Get Involved tab to work on Network Admin.

Props courane01, ryelle, audrasjb.
See #23348.

#135 @audrasjb
12 months ago

👆 second core committer review welcome for the above [56309] changeset.

#136 @joedolson
12 months ago

  • Owner changed from oglekler to joedolson
  • Status changed from reopened to reviewing

#137 @joedolson
12 months ago

  • Keywords dev-reviewed added

[56309] looks good to me. Adding dev-reviewed.

#138 @joedolson
12 months ago

In 56310:

Help/About: Fix the Get Involved tab on Network Admin.

This changeset adds a wp-admin/network/contribute.php file to allow the Get Involved tab to work on Network Admin.

Props courane01, ryelle, audrasjb.
Reviewed by joedolson.
Merges [56309] to the 6.3 branch.
See #23348.

#139 @joedolson
12 months ago

  • Owner changed from joedolson to ogleker

#140 @joedolson
12 months ago

  • Owner changed from ogleker to oglekler

#142 @SergeyBiryukov
12 months ago

In 56311:

Help/About: Update “Get involved in WordPress” link on the Credits tab.

This commit updates the link URL to send contributors to an orientation tool for a short survey on what team they may be interested in joining. This coincides with the Get Involved tab.

Follow-up to [17877], [26354], [35898], [43032], [56220].

Props courane01, audrasjb.
See #23348.

@SergeyBiryukov commented on PR #4909:


12 months ago
#143

Thanks for the PR! Merged in r56311.

#144 @SergeyBiryukov
12 months ago

  • Keywords dev-feedback added; dev-reviewed removed

Marking [56311] for backporting to the 6.3 branch after a second committer's review.

#145 @audrasjb
12 months ago

  • Keywords dev-reviewed added; dev-feedback removed

Approving [56311] for 6.3 backport.

#146 @SergeyBiryukov
12 months ago

In 56312:

Help/About: Update “Get involved in WordPress” link on the Credits tab.

This commit updates the link URL to send contributors to an orientation tool for a short survey on what team they may be interested in joining. This coincides with the Get Involved tab.

Follow-up to [17877], [26354], [35898], [43032], [56220].

Props courane01, audrasjb.
Reviewed by audrasjb, SergeyBiryukov.
Merges [56311] to the 6.3 branch.
See #23348.

This ticket was mentioned in Slack in #meta by courtneyengle. View the logs.


12 months ago

#148 @audrasjb
12 months ago

  • Resolution set to fixed
  • Status changed from reviewing to closed

Closing as fixed. Thanks everyone!

#150 follow-up: @audrasjb
12 months ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

Reopening the ticket to make all the https://make.wordpress.org/contribute/ links translatable so Locale Managers / General translation editors can suer their own link to point to a translated page on their Rosetta website.

This was discussed in the Polyglots slack channel: https://wordpress.slack.com/archives/C02RP50LK/p1690828232964869

#151 @audrasjb
12 months ago

  • Keywords dev-feedback added; dev-reviewed removed

#153 @audrasjb
12 months ago

In 56327:

Help/About: Make Contribute links translatable.

Follow-up to [17877], [26354], [35898], [43032], [56220], [56312].

Props sereedmedia, tobifjellner, oglekler, ryelle, fierevere, davidbaumwald, audrasjb.
See #23348.

#154 @audrasjb
12 months ago

  • Keywords dev-reviewed added; dev-feedback removed

Reviewed by @davidbaumwald directly in the above PR.
I'm going to backport it to 6.3 right now.

@audrasjb commented on PR #4943:


12 months ago
#155

committed in 56327

#156 @audrasjb
12 months ago

In 56328:

Help/About: Make Contribute links translatable.

Follow-up to [17877], [26354], [35898], [43032], [56220], [56312].

Props sereedmedia, tobifjellner, oglekler, ryelle, fierevere, davidbaumwald, audrasjb.
Reviewed by davidbaumwald.
Merges [56327] to the 6.3 branch.
See #23348.

#157 in reply to: ↑ 150 @SergeyBiryukov
12 months ago

Replying to audrasjb:

Reopening the ticket to make all the https://make.wordpress.org/contribute/ links translatable

Thanks! Could we escape these links then, for consistency with how it's done for other translatable links in the admin?

See 23348.6.diff.

#159 @davidbaumwald
12 months ago

To make sure it's not lost, I also asked if the target="_blank" could be removed.

#160 @audrasjb
12 months ago

Thanks for the patch @SergeyBiryukov. I'm going to commit it alongside https://github.com/WordPress/wordpress-develop/pull/4944 by @davidbaumwald

#161 @audrasjb
12 months ago

In 56335:

Help/About: Remove target="_blank" from the Contribute link.

Props davidbaumwald.
See #23348.

#162 @audrasjb
12 months ago

In 56336:

Help/About: Remove target="_blank" from the Contribute link.

Props davidbaumwald.
Reviewed by audrasjb.
Merges [56335] to the 6.3 branch.
See #23348.

#163 @audrasjb
12 months ago

In 56337:

Help/About: Escape "Contribute" links, for better consistency.

Props SergeyBiryukov, peterwilsoncc.
See #23348.

#164 @audrasjb
12 months ago

In 56338:

Help/About: Escape "Contribute" links, for better consistency.

Props SergeyBiryukov, peterwilsoncc.
Reviewed by peterwilsoncc, audrasjb.
Merges [56337] to the 6.3 branch.
See #23348.

#165 @audrasjb
12 months ago

  • Resolution set to fixed
  • Status changed from reopened to closed

I think we're all good!
Closing this ticket as fixed.

Thanks everyone!

This ticket was mentioned in Slack in #meta by sereedmedia. View the logs.


11 months ago

Note: See TracTickets for help on using tickets.