WordPress.org

Make WordPress Core

#23754 closed feature request (duplicate)

Add Bulk Install Option for Favorites

Reported by: smub Owned by:
Milestone: Priority: normal
Severity: minor Version: 3.5.1
Component: Plugins Keywords:
Focuses: Cc:

Description

I really love the "favorites" feature that was added under Install New plugins. I mostly use it to add a lot of the same plugins on new setups that we do for beginner users.

I think it would be very helpful, if we can add a bulk install option using checkboxes. So basically, you can select all or selected plugins from that user's favorites and install them in one click.

Right now the process is not as straight forward. You click on the install button, and it takes you to the new screen that shows the plugin has been installed and activated.

If you want to install more plugins from that user's favorites, then you have to click on the back screen. Alternatively, you can open each install link in a new tab.

Not sure if this is just me or if other people would find it useful too. This is why I am creating this ticket in hopes that it might get included in future versions.

Change History (7)

comment:1 follow-up: mbootsman13 months ago

  • Cc mbootsman added

There is a plugin for that: http://wordpress.org/extend/plugins/bulk-plugin-installation/
Maybe that plugin can be improved by importing someones favorites.

comment:2 mordauk13 months ago

  • Cc pippin@… added

comment:3 in reply to: ↑ 1 smub13 months ago

Replying to mbootsman:

There is a plugin for that: http://wordpress.org/extend/plugins/bulk-plugin-installation/
Maybe that plugin can be improved by importing someones favorites.

I'm aware of that plugin, but it seems counter productive to install one plugin that would allow me to install other plugins. Perhaps an improvement of that plugin can be added in the core?

comment:4 Confridin13 months ago

I agree : i think using a plugin to do that is a nosense. WordPress already allows us to bulk upsate plugin. It could just be added to bulk install favorited plugins.

comment:5 kpdesign13 months ago

  • Cc kpdesign3@… added

I would find this extremely useful as well.

comment:6 sabreuse13 months ago

  • Cc sabreuse added

comment:7 DrewAPicture13 months ago

  • Keywords needs-patch removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #22029.

Note: See TracTickets for help on using tickets.