WordPress.org

Make WordPress Core

Opened 13 months ago

Closed 13 months ago

Last modified 13 months ago

#23814 closed defect (bug) (duplicate)

non-public post types which are shown in admin ui still have 'view post' message

Reported by: netweblogic Owned by:
Milestone: Priority: normal
Severity: minor Version:
Component: Posts, Post Types Keywords:
Focuses: Cc:

Description

When using CPTs that are public = false yet can be edited in the admin, it will still show a 'View post' link in the updated message when creating/updating a CPT.

This is not right because this leads to a 404 page. When viewing the admin list of that CPT the hoverable actions do not show the 'view' link, which is correct.

Simple example to reproduce the issue:

function codex_custom_init() {
	$args = array( 'public' => false, 'show_ui' => true, 'show_in_admin_bar' => true, 'label' => 'Books' );
	register_post_type( 'book', $args );
}
add_action( 'init', 'codex_custom_init' );

flick 'public' on and off, saving permalinks in between and try saving book CPTs to see the 'view post' link as well as a 404 page if public = false.

Change History (3)

comment:1 netweblogic13 months ago

  • Cc msykes@… added

comment:2 DrewAPicture13 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #17609.

comment:3 netweblogic13 months ago

thx, searched but did not find!

Note: See TracTickets for help on using tickets.