WordPress.org

Make WordPress Core

Opened 9 years ago

Closed 9 years ago

#23946 closed defect (bug) (duplicate)

Parsing of Text in the Chat Post Type

Reported by: RDall Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.6
Component: Post Formats Keywords: has-patch
Focuses: Cc:

Description

I posted a dummy chat conversation with myself for styling purposes and I bolded the text of the name. The result in was that the text was bolded but the front tag was also included.

See sandbox dev build here: http://sandbox.robertdall.com/?p=1354

And a additional screenshot incase the dev build is not available. http://cl.ly/image/2e2E0x182D0R

ps. I only talk to myself in dev… don't tell my clients… 

Attachments (1)

23946.diff (471 bytes) - added by wonderboymusic 9 years ago.

Download all attachments as: .zip

Change History (8)

#1 @SergeyBiryukov
9 years ago

  • Component changed from General to Post Formats
  • Milestone changed from Awaiting Review to 3.6

Related: #23625

#2 @TravisHoffman
9 years ago

From viewing source on your example site it looks as if htmlentities got called on the <strong>. I have been unable to reproduce the issue myself. Where exactly did you paste it from?

Travis

#3 @RDall
9 years ago

I am sorry Travis. I don't understand the exact question your asking?

#4 @TravisHoffman
9 years ago

I am just trying to reproduce the bug. I am wondering if you pasted the post content from an outside source or if you hand typed it.

#5 @TravisHoffman
9 years ago

Never mind I just reproduced it =D

@wonderboymusic
9 years ago

#6 @wonderboymusic
9 years ago

  • Keywords has-patch added; needs-patch removed

Since we want structured / raw data and not tag soup, strip_tags() will do the trick

#7 @wonderboymusic
9 years ago

  • Milestone 3.6 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #23625.

http://core.trac.wordpress.org/attachment/ticket/23625/23625.14.diff does the strip_tags() as well - let's close this as a dupe of that

Note: See TracTickets for help on using tickets.