Make WordPress Core

Opened 11 years ago

Closed 11 years ago

#24125 closed defect (bug) (duplicate)

Line breaks in table cells lost when switching from Visual > Text editor

Reported by: ericlewis's profile ericlewis Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.2
Component: Editor Keywords:
Focuses: Cc:

Description

Steps to Reproduce

  1. Create a new post
  2. Add this code in the Text editor to get a basic table with one cell
    <table>
    <tbody>
    <tr>
    <td>Line 1</td>
    </tr>
    </tbody>
    </table>
    
  3. Switch to the Visual editor. Put the cursor after Line 1 in the cell. Press return. Enter something in Line 2 of the table cell
  4. Save post
  5. On Edit post refresh, click Text editor tab.
  6. The two lines will have been concatenated, and switching back to Visual editor now will show that the line break has been lost.

Change History (2)

#1 @ericlewis
11 years ago

  • Version set to trunk

#2 @SergeyBiryukov
11 years ago

  • Keywords needs-patch removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version changed from trunk to 3.2

Duplicate of #20943.

Note: See TracTickets for help on using tickets.