WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#24260 closed defect (bug) (fixed)

Image Post Format: Intermediate Image Size Selection Not Retained

Reported by: chipbennett Owned by:
Milestone: 3.6 Priority: normal
Severity: normal Version: 3.6
Component: Post Formats Keywords:
Focuses: Cc:

Description

Steps to reproduce:

  1. New post
  2. Image post format
  3. Select/Upload image
  4. Image library
  5. Select/Highlight existing image
  6. Change image size from default "thumbnail" to "large"
  7. Select Image button (insert into post)

Result:

The "Image HTML or URL" outputs the image as thumbnail, rather than as large. For example:

[caption width="150" id="attachment_771" align="alignnone"]<img src="http://www.example.com/files/2011/07/img_8399.jpg" width="150" height="150" alt="Boat Barco Texture" class="wp-image-771 size-thumbnail" /> Boat BW PB Barco Texture Beautiful Fishing[/caption]

It appears that the Select/Upload Image modal image size selection is either being ignored or reset.

I repeated the process with a new/uploaded image, with the same outcome.

Change History (4)

comment:2 @SergeyBiryukov2 years ago

  • Milestone changed from Awaiting Review to 3.6

comment:3 @kovshenin2 years ago

  • Keywords close added

Alignment, link and size can no longer be changed for the image post format since [24226].

comment:4 @SergeyBiryukov2 years ago

  • Keywords close removed
  • Resolution set to fixed
  • Status changed from new to closed

Fixed in [24226].

Note: See TracTickets for help on using tickets.