WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#24394 closed enhancement (duplicate)

is_ssl does not recognize ssl when behind a proxy

Reported by: ziodave Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.6
Component: General Keywords:
Focuses: Cc:
PR Number:

Description

There are cases in which WordPress is installed as backed server to a front-end proxy.

The front-end proxy is set to use SSL while the connection between the front-end proxy and the back-end WordPress happens in plain HTTP.

In the above scenario WordPress does not realize that clients are connecting via https and returns the incorrect url when using functions that rely on is_ssl (e.g. plugins_url).

I would suggest adding a global configuration constant, e.g. FORCE_SSL that would forse is_ssl to always return true.

Thanks.

Change History (3)

#1 @markoheijnen
7 years ago

From older tickets this isn't a bug in WordPress but in server configuration. See http://core.trac.wordpress.org/ticket/15733.

#2 @ziodave
7 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #15733.

Thanks, that helped. I'll mark this ticket as a duplicated then.

#3 @ocean90
7 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.