WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 7 years ago

#24809 closed enhancement (duplicate)

Number of terms does not live update on taxonomy list tables (edit taxonomy screens)

Reported by: Hixon10 Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0
Component: Taxonomy Keywords:
Focuses: administration Cc:

Description

When I add a category using Ajax request (http://example.com/wp-admin/edit-tags.php?taxonomy=category), wordpress does not recalculate the number of categories (<span class="displaying-num">...</span>).

Attachments (1)

bbfebef2_o.png (6.8 KB) - added by alexvorn2 8 years ago.
right-bottom corner, 1 Item - should be 3 Items

Download all attachments as: .zip

Change History (10)

#1 @helen
8 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #14485.

#2 @SergeyBiryukov
8 years ago

  • Component changed from Graphic Design to Taxonomy
  • Version changed from 3.5.2 to 3.0

#3 follow-up: @johnbillion
8 years ago

I don't think this is a dupe of #14485. This ticket is talking about the UI on the edit-tags screen when you add a term and the AJAX request goes off and adds it. The "{n} items" elements at the top and bottom of the list table don't get updated.

#14485 is for the cache stuff behind the scenes.

Last edited 8 years ago by johnbillion (previous) (diff)

#4 @alexvorn2
8 years ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened
  • Summary changed from Wrong calculation of the number of categories to Wrong calculation of the number of categories on the edit-tags screen

@alexvorn2
8 years ago

right-bottom corner, 1 Item - should be 3 Items

#5 @alexvorn2
8 years ago

  • Keywords needs-patch added

#6 in reply to: ↑ 3 @helen
8 years ago

  • Component changed from Taxonomy to Administration
  • Milestone set to Awaiting Review
  • Summary changed from Wrong calculation of the number of categories on the edit-tags screen to Number of terms does not live update on taxonomy list tables (edit taxonomy screens)
  • Type changed from defect (bug) to enhancement

Replying to johnbillion:

This ticket is talking about the UI on the edit-tags screen when you add a term and the AJAX request goes off and adds it.

Yeah, I think you're right. I read it as something triggered elsewhere. Comments does do this correctly.

#7 @nacin
8 years ago

  • Component changed from Administration to Taxonomy
  • Focuses administration added

#8 @wonderboymusic
7 years ago

  • Milestone changed from Awaiting Review to Future Release

We should patch this.

#9 @SergeyBiryukov
7 years ago

  • Keywords needs-patch removed
  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from reopened to closed

Duplicate of #18553.

Note: See TracTickets for help on using tickets.