WordPress.org

Make WordPress Core

#25463 closed defect (bug) (duplicate)

Bug in media uploader: filenames containing %20 does not get sanitized

Reported by: chriswoodley Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.6.1
Component: Media Keywords:
Focuses: Cc:

Description

On my server, I uploaded a file with a space in the filename and WordPress or Gravity Forms made it safe by converting the space into a hyphen, like a permalink. That image I could download just fine.

I then uploaded a file with a %20 in the filename (instead of the space) and that filename was left alone, and stored on the server with that name (with the %20 in it) and I could not access that file by URL with or without the %20 in it (either with a space or a %20.)

Then I uploaded an image with the WordPress media manager with the %20 in the filename, and it too is not accessible by URL with the %20 in it. It appears that WordPress does not convert the %20.

Change History (1)

comment:1 @SergeyBiryukov20 months ago

  • Component changed from General to Media
  • Keywords needs-testing removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #18412.

Note: See TracTickets for help on using tickets.