WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 months ago

#25597 closed defect (bug) (duplicate)

The capability used for managing tags should be separate from that for categories

Reported by: johnbillion Owned by: johnbillion
Milestone: Priority: normal
Severity: normal Version: 2.3
Component: Role/Capability Keywords: needs-patch needs-unit-tests
Focuses: Cc:

Description

The capability used for managing categories is manage_categories. Guess what it is for managing tags? It's not manage_tags, nor manage_post_tags. It's manage_categories too.

This causes a problem when you're trying to control capabilities for tags and categories separately.

The patch to change the capability for tags to manage_post_tags is a simple one, but it could potentially introduce an issue where people who have the manage_categories capability would no longer be able to manage tags.

Thoughts? Should this be changed?

Change History (6)

#1 @nacin
3 years ago

I never really understood this either.

#2 @jdgrimes
3 years ago

What about custom taxonomies? Could we do something like 'manage_terms', and then pass in the taxonomy slug for finer grained control? Or would something like that even work?

#3 @chriscct7
14 months ago

  • Keywords needs-patch added

#5 @johnbillion
3 months ago

  • Keywords needs-unit-tests added; dev-feedback removed
  • Milestone changed from Awaiting Review to 4.7
  • Owner set to johnbillion
  • Status changed from new to assigned

#6 @johnbillion
3 months ago

  • Milestone 4.7 deleted
  • Resolution set to duplicate
  • Status changed from assigned to closed

Marking as a dupe of #35614. This is effectively a subset of that ticket.

Note: See TracTickets for help on using tickets.