WordPress.org

Make WordPress Core

Opened 5 months ago

Closed 5 months ago

Last modified 4 months ago

#26139 closed defect (bug) (fixed)

"Add new theme" link broken in 3.8 beta

Reported by: wet Owned by: SergeyBiryukov
Milestone: 3.8 Priority: normal
Severity: normal Version: 3.8
Component: Appearance Keywords: has-patch commit
Focuses: Cc:

Description

Steps to reproduce:

  1. Navigate to Dashboard > Appearance > Theme.
  2. Hover over the "Add new theme" box at the last position in the screenshot gallery.
  3. Notice the link going to ../wp-admin/undefined which obviously will not help in adding a new theme.

theme.js grabs the install URI from an undefined variable named themes.data.settings.install_uri while the actual setting's name is themes.data.settings.installURI.

Attached patch fixes this issue.

Attachments (1)

theme-js-add-theme.patch (852 bytes) - added by wet 5 months ago.

Download all attachments as: .zip

Change History (4)

wet5 months ago

comment:1 markoheijnen5 months ago

  • Keywords commit added
  • Milestone changed from Awaiting Review to 3.8

caused by a cleanup in [26291]

comment:2 SergeyBiryukov5 months ago

  • Owner set to SergeyBiryukov
  • Resolution set to fixed
  • Status changed from new to closed

In 26303:

Use correct variable. props wet. fixes #26139.

comment:3 lancewillett4 months ago

  • Component changed from Themes to Appearance
Note: See TracTickets for help on using tickets.