WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 5 years ago

#26656 closed defect (bug) (worksforme)

Timezone America/Montreal has disappeared from Settings' dropdown

Reported by: jfarsen Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.8
Component: Date/Time Keywords:
Focuses: Cc:

Description

As of a few weeks ago, all of our client sites have been reset to the Africa/Abidjan timezone. All those sites were previously set to America/Montreal.

Furthermore, the America/Montreal choice no longer appears in the drop-down list of timezones.

PHP still lists Montreal as a valid timezone at http://php.net/manual/en/timezones.america.php

Change History (8)

#1 @jfarsen
6 years ago

Edit: This is on a dedicated server configured for shared hosting, under our control.
Server is on auto-update for all OS and cPanel packages, currently at cPanel 11.40.x, on top of CentOS 6.4.x 64-bit. PHP version 5.4.22

#2 @zoonini
6 years ago

  • Cc kathryn@… added

#3 @jfarsen
6 years ago

Edit: Could this be related to the change in status of the timezone (from distinct to linked), as described in this PHP bug: https://bugs.php.net/bug.php?id=66102

#4 @jfarsen
6 years ago

A client of ours has tested this on a different server at a different hosting provided and the problem is not present on 5.3.22, but as soon as he switched to the 5.4 branch, the problem appeared.

#5 @nacin
6 years ago

Thanks for the report. The timezone list comes directly from PHP, so it sounds like https://bugs.php.net/bug.php?id=66102 is the issue. We've looked into a better UI for this (like #10660) but that won't change where the list comes from.

It's possible that WP core acts weird when a chosen timezone is no longer defined, which could be why it shows Africa/Abidjan (which would be about 0 lat/long). That said resetting to UTC-0 is just about the only thing we can do here.

#6 @SergeyBiryukov
6 years ago

  • Component changed from Administration to Date/Time

Could not reproduce on PHP 5.2.14.

WordPress uses timezone_identifiers_list() PHP function to display the Timezone dropdown:
tags/3.8/src/wp-includes/functions.php#L3481.

If there's a bug in a recent PHP version with America/Montreal timezone, I don't think we can do anything here.

#7 @richardmtl
6 years ago

  • Cc richard@… added

#8 @nacin
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.