WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#26827 closed defect (bug) (duplicate)

Using ! (exclamation mark) in rewrite rules causes an error

Reported by: kapooostin Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Rewrite Rules Keywords: has-patch
Focuses: Cc:

Description (last modified by ocean90)

An error is caused by exclamation marks used as regexp delimiters in wp-includes/rewrite.php, line 357 (WP 3.8).

There was similar ticket prior to WP 3.0 #7486, that was closed.

Maybe using ` as the delimiter would be more bulletproof.

Attachments (1)

patch.diff (609 bytes) - added by bansod_deven 4 years ago.
Patch for the Bug ! Hope it Works ! Just Changed the Delimiter from ' ! ' to ' ` '

Download all attachments as: .zip

Change History (6)

#1 @ocean90
4 years ago

  • Description modified (diff)

@bansod_deven
4 years ago

Patch for the Bug ! Hope it Works ! Just Changed the Delimiter from ' ! ' to ' ` '

#2 @SergeyBiryukov
4 years ago

  • Keywords has-patch added; needs-patch removed
  • Milestone changed from Awaiting Review to 3.9

#3 @SergeyBiryukov
4 years ago

@bansod_deven: Uploading attachments doesn't trigger email notifications, so whenever you've uploaded a patch, please also leave a comment. Thanks!

#4 @bansod_deven
4 years ago

Sorry for Not Adding the Comment. Will do it from now onwards.

#5 @samuelsidler
4 years ago

  • Milestone 3.9 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

This is actually a dupe of #23587, which is also targeted for 3.9.

Note: See TracTickets for help on using tickets.