WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#27039 closed defect (bug) (duplicate)

Twenty Thirteen: Make the menu keyboard accessible

Reported by: Frank Klein Owned by:
Milestone: Priority: low
Severity: normal Version: 3.6
Component: Bundled Theme Keywords:
Focuses: accessibility Cc:

Description

Currently it is not possible to access the drop down menus in Twenty Thirteen using the keyboard. The attached patch fixes this.

It also changes the way that the display of the drop down menus is handled. The problem with using display: none is that the browser doesn't take these elements into account when determining tab order.

If you use another CSS technique for handling this (is Twenty Fourteen does), the tab order will be correct, i.e. it will follow the structure of the lists of which the navigation is composed. You can test this by using Tab and Shift+Tab to navigate forward and backward through the menu items.

Attachments (3)

27039.patch (2.9 KB) - added by Frank Klein 5 years ago.
27039.1.patch (3.6 KB) - added by Frank Klein 5 years ago.
Updated patch that fixes issues with the responsive small menu styles.
24839.twenty-thirteen.2.diff (1.8 KB) - added by joedolson 5 years ago.
Alternate patch for #27039; also attached to #24839

Download all attachments as: .zip

Change History (13)

@Frank Klein
5 years ago

#1 @Frank Klein
5 years ago

  • Keywords has-patch needs-testing added

#2 @samuelsidler
5 years ago

  • Component changed from Themes to Bundled Theme
  • Priority changed from normal to low

#3 @lancewillett
5 years ago

  • Milestone changed from Awaiting Review to 3.9

@Frank Klein
5 years ago

Updated patch that fixes issues with the responsive small menu styles.

#4 @sabreuse
5 years ago

related: #27011

#5 @rhyswynne
5 years ago

Applied this patch to WordPress Trunk (3.9-alpha-27234-src). Tested it on a Windows 7 with Google Chrome (33.0.1750.117), Internet Explorer (11.0.9600.16518) and Firefox (27.0.1

Works fine and as expected.

This ticket was mentioned in IRC in #wordpress-ui by grahamarmfield. View the logs.


5 years ago

#7 @joedolson
5 years ago

This patch will cause problems in RTL languages -- setting the off-left position will generate a scrollbar under RTL reading order. I've attached an alternate patch I created for #24839 that uses the clip technique to hide the menus.

@joedolson
5 years ago

Alternate patch for #27039; also attached to #24839

#8 @lancewillett
5 years ago

  • Milestone 3.9 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #24839.

#10 @lancewillett
5 years ago

  • Keywords has-patch needs-testing removed
Note: See TracTickets for help on using tickets.