Make WordPress Core

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#27235 closed defect (bug) (fixed)

Theme errors are misplaced

Reported by: sergeybiryukov's profile SergeyBiryukov Owned by: nacin's profile nacin
Milestone: 3.8.2 Priority: normal
Severity: normal Version: 3.8
Component: Themes Keywords: has-patch commit fixed-major
Focuses: ui, administration Cc:

Description

If you delete an active theme from the server and visit Themes screen, you'll get a warning mentioned in #26873, but you'll also notice that theme errors are misplaced. See the screenshot.

Attachments (3)

27235.before.png (250.2 KB) - added by SergeyBiryukov 10 years ago.
27235.patch (377 bytes) - added by SergeyBiryukov 10 years ago.
27235.after.png (251.1 KB) - added by SergeyBiryukov 10 years ago.

Download all attachments as: .zip

Change History (8)

#1 @kirasong
10 years ago

  • Keywords fixed-major added

I'm not able to reproduce this after [27745].

It looks like it gets covered by validate_current_theme() and uses the updated class:
http://screen.objects.dreamhost.com/03-26-2014-19-20-40.png

Marking fixed-major, but leaving open for 3.8.2

#2 @kirasong
10 years ago

Leaving this fixed-major, but just to note that while if you removed the active theme it was fixed, this bug would still be valid if you removed the default theme.

Nacin will be committing a fix for this shortly.

#3 @nacin
10 years ago

In 27760:

Themes screen: Use a normal error for WP_Theme errors.

see #27235 for trunk.

#4 @nacin
10 years ago

  • Owner set to nacin
  • Resolution set to fixed
  • Status changed from new to closed

In 27876:

Themes screen: Use a normal error for WP_Theme errors.

Merges [27760] to the 3.8 branch.

fixes #27235.

#5 @nacin
10 years ago

I was going to go with a CSS fix for the 3.8 branch but wp-admin/themes.php is already changing due to [27875].

Note: See TracTickets for help on using tickets.