WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#27500 closed feature request (duplicate)

Turn the "template" metabox functionality for pages into a capability for all CPTs

Reported by: lgladdy Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Posts, Post Types Keywords:
Focuses: ui, template Cc:

Description

Currently, wp-admin/includes/meta-boxes.php has the following code, which determines if the "template" meta box is shown for in the admin:

if ( 'page' == $post->post_type && 0 != count( get_page_templates( $post ) ) ) {

But, custom post types should be able to use this templating functionality too. I'm sure it would need more than just patching meta-boxes.php to enable it, but it would be awesome if this was turned into a registerable capability of custom post types.

Change History (1)

#1 @SergeyBiryukov
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #18375.

Note: See TracTickets for help on using tickets.