WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 4 years ago

#27955 closed defect (bug) (invalid)

Admin bar breaks 'hover-click' functionality on iOS

Reported by: jmichaelward Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.9
Component: Toolbar Keywords: reporter-feedback
Focuses: administration Cc:

Description

I'm working on a couple of client sites where the design features a list of posts that users can hover over to reveal additional information in an overlay, then click the post to get to the single post itself.

During a testing phase, one client discovered that they were not able to click through to any posts using iOS devices. Touching the post activated the overlay, and the 'hover' state was released on touch end without triggering the link. Through testing on several devices, we can to discover that the issue only existed when the client was logged into the WordPress dashboard on their iOS device. When the admin bar was deactivated either through logging out or by using a plugin to deactivate it, all devices functioned as expected.

This issue only appears to affect iOS devices due to its 'hover-click' functionality and was replicable in both current versions of Safari and Chrome. Because Android devices do not have the 'hover-click' functionality built in, clicking on posts with overlays take the user directly to the posts pages.

Change History (3)

#1 @johnbillion
5 years ago

  • Component changed from Administration to Toolbar
  • Focuses ui removed
  • Keywords reporter-feedback added

Thanks for the report jmichaelward. Can you provide some code which allows us to reproduce and investigate the issue?

#2 @jmichaelward
5 years ago

Hi John,

Thanks for the follow-up. I will post some code later tonight.

Best,

Jeremy

#3 @afercia
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

No feedback in 19 months, closing out. Please feel free to re-open with more information.

Note: See TracTickets for help on using tickets.