WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#28040 closed enhancement (duplicate)

Core CSS Standards

Reported by: sdavis2702 Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0
Component: General Keywords: has-patch
Focuses: ui, administration Cc:

Description

This patch 1) attempts to bring core CSS files to the WordPress standard while 2) introducing a little consistency in the formatting ( all based on http://make.wordpress.org/core/handbook/coding-standards/css/ ).

Attachments (1)

css-standards.diff (104.4 KB) - added by sdavis2702 7 years ago.
WordPress CSS standards + formatting consistency

Download all attachments as: .zip

Change History (5)

@sdavis2702
7 years ago

WordPress CSS standards + formatting consistency

#1 @sdavis2702
7 years ago

  • Keywords has-patch added

#2 @SergeyBiryukov
7 years ago

  • Focuses ui administration added

#3 @helen
7 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #20570. We also generally discourage formatting for the sake of formatting - I definitely think we should make a concerted effort for cleanup of CSS in general, but it needs to be organized, not just a monster patch that will frustratingly go stale extremely quickly. See http://make.wordpress.org/core/2011/03/23/code-refactoring/

Your interest is much appreciated.

#4 @sdavis2702
7 years ago

Got it. Didn't see the duplicate. No worries at all. Just out of curiosity, what is considered an organized cleanup of the CSS? I just went through a couple years of discussion and multiple duplicates and it seems that MP6 would have been the point to do something. Patches to the CSS obviously aren't being accepted and CSSComb isn't seen as a good first step https://core.trac.wordpress.org/ticket/20570#comment:32, I can't imagine what else could be done. If you all have suggestions, I'm sure there are more than enough people willing to help clean it up including myself.

Note: See TracTickets for help on using tickets.